commit
8f5a354e93
Binary file not shown.
@ -0,0 +1,23 @@
|
|||||||
|
--- quick-xml-0.27.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ quick-xml-0.27.1/Cargo.toml 2023-05-25T07:59:10.985898+00:00
|
||||||
|
@@ -88,10 +88,6 @@
|
||||||
|
path = "benches/macrobenches.rs"
|
||||||
|
harness = false
|
||||||
|
|
||||||
|
-[dependencies.document-features]
|
||||||
|
-version = "0.2"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
[dependencies.encoding_rs]
|
||||||
|
version = "0.8"
|
||||||
|
optional = true
|
||||||
|
@@ -108,9 +104,6 @@
|
||||||
|
features = ["io-util"]
|
||||||
|
optional = true
|
||||||
|
default-features = false
|
||||||
|
-
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "0.4"
|
||||||
|
|
||||||
|
[dev-dependencies.pretty_assertions]
|
||||||
|
version = "1.3"
|
@ -0,0 +1,194 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate quick-xml
|
||||||
|
|
||||||
|
Name: rust-quick-xml0.27
|
||||||
|
Version: 0.27.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: High performance xml reader and writer
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/quick-xml
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||||
|
# * drop unused, optional document-features dependency
|
||||||
|
Patch: quick-xml-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
High performance xml reader and writer.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+async-tokio-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+async-tokio-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "async-tokio" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+async-tokio-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+encoding-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+encoding-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "encoding" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+encoding-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+encoding_rs-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+encoding_rs-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "encoding_rs" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+encoding_rs-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+escape-html-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+escape-html-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "escape-html" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+escape-html-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+overlapped-lists-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+overlapped-lists-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "overlapped-lists" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+overlapped-lists-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-types-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-types-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde-types" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-types-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serialize-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serialize-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serialize" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serialize-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+tokio-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+tokio-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "tokio" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+tokio-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.27.1-1
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Mon May 29 2023 Fabio Valentini <decathorpe@gmail.com> - 0.27.1-1
|
||||||
|
- Initial import (quick-xml 0.27 compat package)
|
Loading…
Reference in new issue