commit
f48419cbba
Binary file not shown.
@ -0,0 +1,12 @@
|
||||
--- quick-xml-0.31.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ quick-xml-0.31.0/Cargo.toml 2023-12-02T00:35:50.410440+00:00
|
||||
@@ -134,9 +134,6 @@
|
||||
optional = true
|
||||
default-features = false
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.4"
|
||||
-
|
||||
[dev-dependencies.pretty_assertions]
|
||||
version = "1.4"
|
||||
|
@ -0,0 +1,261 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate quick-xml
|
||||
|
||||
Name: rust-quick-xml
|
||||
Version: 0.31.0
|
||||
Release: %autorelease
|
||||
Summary: High performance xml reader and writer
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/quick-xml
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency
|
||||
Patch: quick-xml-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
High performance xml reader and writer.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-MIT.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+arbitrary-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+arbitrary-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "arbitrary" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+arbitrary-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+async-tokio-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+async-tokio-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "async-tokio" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+async-tokio-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+document-features-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+document-features-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "document-features" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+document-features-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+encoding-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+encoding-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "encoding" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+encoding-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+encoding_rs-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+encoding_rs-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "encoding_rs" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+encoding_rs-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+escape-html-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+escape-html-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "escape-html" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+escape-html-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+overlapped-lists-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+overlapped-lists-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "overlapped-lists" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+overlapped-lists-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-types-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-types-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde-types" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-types-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serialize-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serialize-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serialize" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serialize-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tokio-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tokio-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tokio" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tokio-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.31.0-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Sat Dec 02 2023 Fabio Valentini <decathorpe@gmail.com> - 0.31.0-1
|
||||
- Update to version 0.31.0; Fixes RHBZ#2245734
|
||||
|
||||
* Thu Aug 10 2023 Fabio Valentini <decathorpe@gmail.com> - 0.30.0-1
|
||||
- Update to version 0.30.0; Fixes RHBZ#2214395
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.28.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Mon May 29 2023 Fabio Valentini <decathorpe@gmail.com> - 0.28.2-1
|
||||
- Update to version 0.28.2; Fixes RHBZ#2177831
|
||||
|
||||
* Fri Feb 03 2023 Fabio Valentini <decathorpe@gmail.com> - 0.27.1-1
|
||||
- Update to version 0.27.1; Fixes RHBZ#2122015
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.25.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Tue Nov 29 2022 Fabio Valentini <decathorpe@gmail.com> - 0.25.0-1
|
||||
- Update to version 0.25.0
|
||||
|
||||
* Thu Jul 28 2022 Fabio Valentini <decathorpe@gmail.com> - 0.23.0-1
|
||||
- Update to version 0.23.0; Fixes RHBZ#2090320
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Thu May 27 2021 Fabio Valentini <decathorpe@gmail.com> - 0.22.0-1
|
||||
- Update to version 0.22.0.
|
||||
- Fixes RHBZ#1924726
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.20.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Dec 07 2020 Fabio Valentini <decathorpe@gmail.com> - 0.20.0-1
|
||||
- Update to version 0.20.0.
|
||||
|
||||
* Wed Sep 16 2020 Fabio Valentini <decathorpe@gmail.com> - 0.18.1-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue