Update to version 0.21.1; Fixes RHBZ#2265638

epel10
Fabio Valentini 9 months ago
parent 03904caab1
commit f7b6b17502
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -18,3 +18,4 @@
/pyo3-0.20.0.crate /pyo3-0.20.0.crate
/pyo3-0.20.1.crate /pyo3-0.20.1.crate
/pyo3-0.20.2.crate /pyo3-0.20.2.crate
/pyo3-0.21.1.crate

@ -1,26 +0,0 @@
From d4a43723777978e6fb5dca5463da3f5a548b9034 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Fri, 5 Apr 2024 10:55:47 +0200
Subject: [PATCH] drop deny(warnings) from doctests
---
src/lib.rs | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/src/lib.rs b/src/lib.rs
index ecaaf64..c80a3bc 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -7,8 +7,7 @@
deny(
rust_2018_idioms,
unused_lifetimes,
- rust_2021_prelude_collisions,
- warnings
+ rust_2021_prelude_collisions
),
allow(unused_variables, unused_assignments, unused_extern_crates)
)))]
--
2.44.0

@ -1,19 +1,10 @@
--- pyo3-0.20.2/Cargo.toml 1970-01-01T00:00:01+00:00 --- pyo3-0.21.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pyo3-0.20.2/Cargo.toml 2024-01-07T21:04:53.596095+00:00 +++ pyo3-0.21.1/Cargo.toml 2024-04-12T19:22:47.515008+00:00
@@ -156,7 +156,7 @@ @@ -241,7 +241,6 @@
version = ">=1.0.70" "serde",
"smallvec",
[dev-dependencies.widestring]
-version = "0.5.1"
+version = "1.0.2"
[build-dependencies.pyo3-build-config]
version = "=0.20.2"
@@ -217,7 +217,6 @@
"experimental-inspect",
"rust_decimal",
] ]
-generate-import-lib = ["pyo3-ffi/generate-import-lib"] -generate-import-lib = ["pyo3-ffi/generate-import-lib"]
gil-refs = []
macros = [ macros = [
"pyo3-macros", "pyo3-macros",
"indoc",

@ -1,11 +1,11 @@
# Generated by rust2rpm 25 # Generated by rust2rpm 26
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate pyo3 %global crate pyo3
Name: rust-pyo3 Name: rust-pyo3
Version: 0.20.2 Version: 0.21.1
Release: %autorelease Release: %autorelease
Summary: Bindings to Python interpreter Summary: Bindings to Python interpreter
@ -13,11 +13,8 @@ License: MIT OR Apache-2.0
URL: https://crates.io/crates/pyo3 URL: https://crates.io/crates/pyo3
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * bump widestring dev-dependency from 0.5 to 1.0
# * drop MSVC- and MinGW-only features # * drop MSVC- and MinGW-only features
Patch: pyo3-fix-metadata.diff Patch: pyo3-fix-metadata.diff
# drop deny(warnings) from doctests to fix building with recent Rust
Patch: 0001-drop-deny-warnings-from-doctests.patch
BuildRequires: cargo-rpm-macros >= 24 BuildRequires: cargo-rpm-macros >= 24
@ -180,6 +177,18 @@ use the "chrono" feature of the "%{crate}" crate.
%files -n %{name}+chrono-devel %files -n %{name}+chrono-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+chrono-tz-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+chrono-tz-devel %{_description}
This package contains library source intended for building other packages which
use the "chrono-tz" feature of the "%{crate}" crate.
%files -n %{name}+chrono-tz-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+either-devel %package -n %{name}+either-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -192,6 +201,30 @@ use the "either" feature of the "%{crate}" crate.
%files -n %{name}+either-devel %files -n %{name}+either-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+experimental-async-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+experimental-async-devel %{_description}
This package contains library source intended for building other packages which
use the "experimental-async" feature of the "%{crate}" crate.
%files -n %{name}+experimental-async-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+experimental-declarative-modules-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+experimental-declarative-modules-devel %{_description}
This package contains library source intended for building other packages which
use the "experimental-declarative-modules" feature of the "%{crate}" crate.
%files -n %{name}+experimental-declarative-modules-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+experimental-inspect-devel %package -n %{name}+experimental-inspect-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -240,6 +273,18 @@ use the "full" feature of the "%{crate}" crate.
%files -n %{name}+full-devel %files -n %{name}+full-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+gil-refs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+gil-refs-devel %{_description}
This package contains library source intended for building other packages which
use the "gil-refs" feature of the "%{crate}" crate.
%files -n %{name}+gil-refs-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hashbrown-devel %package -n %{name}+hashbrown-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -410,9 +455,9 @@ use the "unindent" feature of the "%{crate}" crate.
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep
# drop files that are not useful # drop files that are not useful
rm -r emscripten/ newsfragments/ rm -r emscripten/ newsfragments/
%cargo_prep
%generate_buildrequires %generate_buildrequires
# unit tests require optional dependencies # unit tests require optional dependencies

@ -0,0 +1,11 @@
[package]
cargo-toml-patch-comments = [
"drop MSVC- and MinGW-only features",
]
[scripts]
prep.post = [
"# drop files that are not useful",
"rm -r emscripten/ newsfragments/",
]

@ -1 +1 @@
SHA512 (pyo3-0.20.2.crate) = cc5151a116179157046ec92677e5a72318b4cdb13a7d7e3bb83778739b5758040e5020f667dd83554a66b758581a08f5de05eb38e7b339813cec85e0712e6355 SHA512 (pyo3-0.21.1.crate) = 6bf1c99b7c0c44ece16b3298f1090891cac2994e25730da8a82981f2296bc2d260b61df08897a2cd6c27c6e90deb70e4c08388fc70eeea6dea4b5cc451ed9598

Loading…
Cancel
Save