Update to version 0.19.2; Fixes RHBZ#2228011

epel10
Fabio Valentini 1 year ago
parent f71092fb50
commit dc59d9a6ba
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -14,3 +14,4 @@
/pyo3-0.18.2.crate
/pyo3-0.18.3.crate
/pyo3-0.19.1.crate
/pyo3-0.19.2.crate

@ -1,82 +1,6 @@
--- pyo3-0.19.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pyo3-0.19.1/Cargo.toml 2023-07-05T16:57:19.970854+00:00
@@ -61,65 +61,6 @@
"docsrs",
]
-[[bench]]
-name = "bench_any"
-harness = false
-
-[[bench]]
-name = "bench_call"
-harness = false
-
-[[bench]]
-name = "bench_err"
-harness = false
-
-[[bench]]
-name = "bench_decimal"
-harness = false
-required-features = ["rust_decimal"]
-
-[[bench]]
-name = "bench_dict"
-harness = false
-
-[[bench]]
-name = "bench_frompyobject"
-harness = false
-required-features = ["macros"]
-
-[[bench]]
-name = "bench_gil"
-harness = false
-
-[[bench]]
-name = "bench_list"
-harness = false
-
-[[bench]]
-name = "bench_pyclass"
-harness = false
-required-features = ["macros"]
-
-[[bench]]
-name = "bench_pyobject"
-harness = false
-
-[[bench]]
-name = "bench_set"
-harness = false
-
-[[bench]]
-name = "bench_tuple"
-harness = false
-
-[[bench]]
-name = "bench_intern"
-harness = false
-
-[[bench]]
-name = "bench_extract"
-harness = false
-
[dependencies.anyhow]
version = "1.0"
optional = true
@@ -194,9 +135,6 @@
[dev-dependencies.chrono]
version = "0.4"
-
-[dev-dependencies.criterion]
-version = "0.3.5"
[dev-dependencies.proptest]
version = "0.10.1"
@@ -213,9 +151,6 @@
--- pyo3-0.19.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pyo3-0.19.2/Cargo.toml 2023-08-01T13:22:43.767928+00:00
@@ -151,9 +151,6 @@
[dev-dependencies.rustversion]
version = "1.0"
@ -86,7 +10,7 @@
[dev-dependencies.serde]
version = "1.0"
features = ["derive"]
@@ -225,9 +160,6 @@
@@ -163,9 +160,6 @@
[dev-dependencies.trybuild]
version = ">=1.0.70"
@ -95,8 +19,8 @@
-version = "0.5.1"
[build-dependencies.pyo3-build-config]
version = "0.19.1"
@@ -281,7 +213,6 @@
version = "0.19.2"
@@ -219,7 +213,6 @@
"experimental-inspect",
"rust_decimal",
]

@ -5,7 +5,7 @@
%global crate pyo3
Name: rust-pyo3
Version: 0.19.1
Version: 0.19.2
Release: %autorelease
Summary: Bindings to Python interpreter
@ -13,8 +13,6 @@ License: Apache-2.0
URL: https://crates.io/crates/pyo3
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop unused benchmark definitions from Cargo.toml
# * drop send_wrapper and widestring dev-dependencies (not packaged yet)
# * drop MSVC- and MinGW-only features
Patch: pyo3-fix-metadata.diff
@ -394,15 +392,8 @@ rm tests/test_pep_587.rs
# * unit tests require an UTF-8 locale
# * unit tests require the "auto-initialize" feature
export LANG=C.utf8
%if 0%{?fedora} >= 39
# * skip a test that fails with Python 3.12:
# https://github.com/PyO3/pyo3/issues/3305
# * skip tests that are unreliable with Python 3.12
%cargo_test -f auto-initialize -- -- --skip err::tests::fetching_panic_exception_resumes_unwind --skip types::dict::tests::test_set_item_refcnt --skip types::list::tests::test_append_refcnt --skip types::list::tests::test_insert_refcnt
%else
%cargo_test -f auto-initialize
%endif
%endif
%changelog
%autochangelog

@ -1 +1 @@
SHA512 (pyo3-0.19.1.crate) = b27500cf49f1c6f217d21344d24ac96c07b82c157dd36fa4550b94059da5715ba7d0e085ec07dd5f8a8ac9de4d7e9239c1cceac4337294eb0dc9f6102049d5ff
SHA512 (pyo3-0.19.2.crate) = 58698183e0f2f0507f8f765bf3e90185c933e78d62f0a9be65c4b1ce8eea19a98fe0341abe7c58cafdacb63a012ec417876dccb7be6facc1360fcb22796fcaf9

Loading…
Cancel
Save