Update to version 0.20.1; Fixes RHBZ#2256286

epel10
Fabio Valentini 1 year ago
parent 1fca351d03
commit 35b4d5bc17
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -16,3 +16,4 @@
/pyo3-0.19.1.crate /pyo3-0.19.1.crate
/pyo3-0.19.2.crate /pyo3-0.19.2.crate
/pyo3-0.20.0.crate /pyo3-0.20.0.crate
/pyo3-0.20.1.crate

@ -1,26 +1,15 @@
--- pyo3-0.20.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- pyo3-0.20.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pyo3-0.20.0/Cargo.toml 2023-11-13T23:46:49.379610+00:00 +++ pyo3-0.20.1/Cargo.toml 2023-12-31T22:04:59.479050+00:00
@@ -149,9 +149,6 @@ @@ -168,7 +168,7 @@
version = "1.8.0"
features = ["std"]
-[dev-dependencies.send_wrapper]
-version = "0.6"
-
[dev-dependencies.serde]
version = "1.0"
features = ["derive"]
@@ -161,9 +158,6 @@
[dev-dependencies.trybuild]
version = ">=1.0.70" version = ">=1.0.70"
-
-[dev-dependencies.widestring] [dev-dependencies.widestring]
-version = "0.5.1" -version = "0.5.1"
+version = "1.0.2"
[build-dependencies.pyo3-build-config] [build-dependencies.pyo3-build-config]
version = "0.20.0" version = "0.20.1"
@@ -217,7 +211,6 @@ @@ -229,7 +229,6 @@
"experimental-inspect", "experimental-inspect",
"rust_decimal", "rust_decimal",
] ]

@ -5,7 +5,7 @@
%global crate pyo3 %global crate pyo3
Name: rust-pyo3 Name: rust-pyo3
Version: 0.20.0 Version: 0.20.1
Release: %autorelease Release: %autorelease
Summary: Bindings to Python interpreter Summary: Bindings to Python interpreter
@ -13,11 +13,9 @@ License: MIT OR Apache-2.0
URL: https://crates.io/crates/pyo3 URL: https://crates.io/crates/pyo3
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop send_wrapper and widestring dev-dependencies (not packaged yet) # * bump widestring dev-dependency from 0.5 to 1.0
# * drop MSVC- and MinGW-only features # * drop MSVC- and MinGW-only features
Patch: pyo3-fix-metadata.diff Patch: pyo3-fix-metadata.diff
# * skip the single doctest that depends on send_wrapper
Patch: 0001-ignore-doctests-with-missing-send_wrapper-dependency.patch
BuildRequires: cargo-rpm-macros >= 24 BuildRequires: cargo-rpm-macros >= 24
@ -96,6 +94,18 @@ use the "abi3-py311" feature of the "%{crate}" crate.
%files -n %{name}+abi3-py311-devel %files -n %{name}+abi3-py311-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+abi3-py312-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+abi3-py312-devel %{_description}
This package contains library source intended for building other packages which
use the "abi3-py312" feature of the "%{crate}" crate.
%files -n %{name}+abi3-py312-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+abi3-py37-devel %package -n %{name}+abi3-py37-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -168,6 +178,18 @@ use the "chrono" feature of the "%{crate}" crate.
%files -n %{name}+chrono-devel %files -n %{name}+chrono-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+either-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+either-devel %{_description}
This package contains library source intended for building other packages which
use the "either" feature of the "%{crate}" crate.
%files -n %{name}+either-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+experimental-inspect-devel %package -n %{name}+experimental-inspect-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -360,6 +382,18 @@ use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+smallvec-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+smallvec-devel %{_description}
This package contains library source intended for building other packages which
use the "smallvec" feature of the "%{crate}" crate.
%files -n %{name}+smallvec-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unindent-devel %package -n %{name}+unindent-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -376,8 +410,6 @@ use the "unindent" feature of the "%{crate}" crate.
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version} -p1
# drop files that are not useful # drop files that are not useful
rm -r emscripten/ newsfragments/ rm -r emscripten/ newsfragments/
# drop the tests for which dependencies were removed
rm tests/test_pep_587.rs
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -1 +1 @@
SHA512 (pyo3-0.20.0.crate) = 85d9533c75f905752c62f6a4898582ae48daf085e287b44949c47260301205a5f00477927877ce46300d2801d22fbc04a958c058a37eb28374c834fff27feca1 SHA512 (pyo3-0.20.1.crate) = f49a8570b4ed535ef6ac209b080e0612e1185babc2436aa488e29aecb7abcecc12ccf2214225ac17ef38c6c38d343dc8c2a186890e795b81c59ccf2a2ec8509e

Loading…
Cancel
Save