Update to version 0.20.0; Fixes RHBZ#2243412

epel10
Fabio Valentini 1 year ago
parent dc59d9a6ba
commit 1fca351d03
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -15,3 +15,4 @@
/pyo3-0.18.3.crate /pyo3-0.18.3.crate
/pyo3-0.19.1.crate /pyo3-0.19.1.crate
/pyo3-0.19.2.crate /pyo3-0.19.2.crate
/pyo3-0.20.0.crate

@ -1,6 +1,6 @@
From 1a011b0266117687ff2b2d2de588064af964b968 Mon Sep 17 00:00:00 2001 From 36f1b42e44f2cd2cfc3e14b0a4ab7c5cf9904bf7 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com> From: Fabio Valentini <decathorpe@gmail.com>
Date: Wed, 5 Jul 2023 19:13:56 +0200 Date: Tue, 14 Nov 2023 00:51:33 +0100
Subject: [PATCH] ignore doctests with missing send_wrapper dependency Subject: [PATCH] ignore doctests with missing send_wrapper dependency
--- ---
@ -8,7 +8,7 @@ Subject: [PATCH] ignore doctests with missing send_wrapper dependency
1 file changed, 3 insertions(+), 3 deletions(-) 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/marker.rs b/src/marker.rs diff --git a/src/marker.rs b/src/marker.rs
index e5b3ed8..343bbb4 100644 index dfe876c..1352276 100644
--- a/src/marker.rs --- a/src/marker.rs
+++ b/src/marker.rs +++ b/src/marker.rs
@@ -66,7 +66,7 @@ @@ -66,7 +66,7 @@
@ -20,7 +20,7 @@ index e5b3ed8..343bbb4 100644
//! use pyo3::prelude::*; //! use pyo3::prelude::*;
//! use pyo3::types::PyString; //! use pyo3::types::PyString;
//! use send_wrapper::SendWrapper; //! use send_wrapper::SendWrapper;
@@ -158,7 +158,7 @@ use std::os::raw::c_int; @@ -157,7 +157,7 @@ use std::os::raw::c_int;
/// This also implies that the interplay between `with_gil` and `allow_threads` is unsound, for example /// This also implies that the interplay between `with_gil` and `allow_threads` is unsound, for example
/// one can circumvent this protection using the [`send_wrapper`](https://docs.rs/send_wrapper/) crate: /// one can circumvent this protection using the [`send_wrapper`](https://docs.rs/send_wrapper/) crate:
/// ///
@ -29,7 +29,7 @@ index e5b3ed8..343bbb4 100644
/// # use pyo3::prelude::*; /// # use pyo3::prelude::*;
/// # use pyo3::types::PyString; /// # use pyo3::types::PyString;
/// use send_wrapper::SendWrapper; /// use send_wrapper::SendWrapper;
@@ -225,7 +225,7 @@ unsafe impl<T: Send> Ungil for T {} @@ -231,7 +231,7 @@ mod nightly {
/// On nightly Rust, this is not based on the [`Send`] auto trait and hence we are able /// On nightly Rust, this is not based on the [`Send`] auto trait and hence we are able
/// to prevent incorrectly circumventing it using e.g. the [`send_wrapper`](https://docs.rs/send_wrapper/) crate: /// to prevent incorrectly circumventing it using e.g. the [`send_wrapper`](https://docs.rs/send_wrapper/) crate:
/// ///

@ -1,8 +1,8 @@
--- pyo3-0.19.2/Cargo.toml 1970-01-01T00:00:01+00:00 --- pyo3-0.20.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pyo3-0.19.2/Cargo.toml 2023-08-01T13:22:43.767928+00:00 +++ pyo3-0.20.0/Cargo.toml 2023-11-13T23:46:49.379610+00:00
@@ -151,9 +151,6 @@ @@ -149,9 +149,6 @@
[dev-dependencies.rustversion] version = "1.8.0"
version = "1.0" features = ["std"]
-[dev-dependencies.send_wrapper] -[dev-dependencies.send_wrapper]
-version = "0.6" -version = "0.6"
@ -10,7 +10,7 @@
[dev-dependencies.serde] [dev-dependencies.serde]
version = "1.0" version = "1.0"
features = ["derive"] features = ["derive"]
@@ -163,9 +160,6 @@ @@ -161,9 +158,6 @@
[dev-dependencies.trybuild] [dev-dependencies.trybuild]
version = ">=1.0.70" version = ">=1.0.70"
@ -19,8 +19,8 @@
-version = "0.5.1" -version = "0.5.1"
[build-dependencies.pyo3-build-config] [build-dependencies.pyo3-build-config]
version = "0.19.2" version = "0.20.0"
@@ -219,7 +213,6 @@ @@ -217,7 +211,6 @@
"experimental-inspect", "experimental-inspect",
"rust_decimal", "rust_decimal",
] ]

@ -1,15 +1,15 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate pyo3 %global crate pyo3
Name: rust-pyo3 Name: rust-pyo3
Version: 0.19.2 Version: 0.20.0
Release: %autorelease Release: %autorelease
Summary: Bindings to Python interpreter Summary: Bindings to Python interpreter
License: Apache-2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/pyo3 URL: https://crates.io/crates/pyo3
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
@ -19,7 +19,7 @@ Patch: pyo3-fix-metadata.diff
# * skip the single doctest that depends on send_wrapper # * skip the single doctest that depends on send_wrapper
Patch: 0001-ignore-doctests-with-missing-send_wrapper-dependency.patch Patch: 0001-ignore-doctests-with-missing-send_wrapper-dependency.patch
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
Bindings to Python interpreter.} Bindings to Python interpreter.}
@ -36,7 +36,10 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license %{crate_instdir}/LICENSE %license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%license %{crate_instdir}/pyo3-runtime/LICENSE-APACHE
%license %{crate_instdir}/pyo3-runtime/LICENSE-MIT
%doc %{crate_instdir}/Architecture.md %doc %{crate_instdir}/Architecture.md
%doc %{crate_instdir}/CHANGELOG.md %doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/Code-of-Conduct.md %doc %{crate_instdir}/Code-of-Conduct.md
@ -370,7 +373,7 @@ use the "unindent" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
# drop files that are not useful # drop files that are not useful
rm -r emscripten/ newsfragments/ rm -r emscripten/ newsfragments/
# drop the tests for which dependencies were removed # drop the tests for which dependencies were removed

@ -1 +1 @@
SHA512 (pyo3-0.19.2.crate) = 58698183e0f2f0507f8f765bf3e90185c933e78d62f0a9be65c4b1ce8eea19a98fe0341abe7c58cafdacb63a012ec417876dccb7be6facc1360fcb22796fcaf9 SHA512 (pyo3-0.20.0.crate) = 85d9533c75f905752c62f6a4898582ae48daf085e287b44949c47260301205a5f00477927877ce46300d2801d22fbc04a958c058a37eb28374c834fff27feca1

Loading…
Cancel
Save