Initial import (#2161765)
parent
b8efeae492
commit
e3bfcfa1af
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/pyo3-ffi-0.16.6.crate
|
@ -0,0 +1,8 @@
|
||||
--- pyo3-ffi-0.16.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ pyo3-ffi-0.16.6/Cargo.toml 2023-01-17T18:57:26.978820+00:00
|
||||
@@ -58,5 +58,3 @@
|
||||
]
|
||||
default = []
|
||||
extension-module = ["pyo3-build-config/extension-module"]
|
||||
-generate-abi3-import-lib = ["generate-import-lib"]
|
||||
-generate-import-lib = ["pyo3-build-config/python3-dll-a"]
|
@ -0,0 +1,149 @@
|
||||
# Generated by rust2rpm 23
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate pyo3-ffi
|
||||
|
||||
Name: rust-pyo3-ffi
|
||||
Version: 0.16.6
|
||||
Release: %autorelease
|
||||
Summary: Python-API bindings for the PyO3 ecosystem
|
||||
|
||||
License: Apache-2.0
|
||||
URL: https://crates.io/crates/pyo3-ffi
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop MSVC- and MinGW-only features
|
||||
Patch: pyo3-ffi-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Python-API bindings for the PyO3 ecosystem.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
Requires: python3-devel >= 3.7
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+abi3-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+abi3-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "abi3" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+abi3-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+abi3-py310-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
Requires: python3-devel >= 3.10
|
||||
|
||||
%description -n %{name}+abi3-py310-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "abi3-py310" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+abi3-py310-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+abi3-py37-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
Requires: python3-devel >= 3.7
|
||||
|
||||
%description -n %{name}+abi3-py37-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "abi3-py37" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+abi3-py37-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+abi3-py38-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
Requires: python3-devel >= 3.8
|
||||
|
||||
%description -n %{name}+abi3-py38-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "abi3-py38" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+abi3-py38-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+abi3-py39-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
Requires: python3-devel >= 3.9
|
||||
|
||||
%description -n %{name}+abi3-py39-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "abi3-py39" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+abi3-py39-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+extension-module-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+extension-module-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "extension-module" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+extension-module-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
echo 'python3-devel >= 3.7'
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,13 @@
|
||||
[DEFAULT]
|
||||
buildrequires =
|
||||
python3-devel >= 3.7
|
||||
lib+default.requires =
|
||||
python3-devel >= 3.7
|
||||
lib+abi3-py37.requires =
|
||||
python3-devel >= 3.7
|
||||
lib+abi3-py38.requires =
|
||||
python3-devel >= 3.8
|
||||
lib+abi3-py39.requires =
|
||||
python3-devel >= 3.9
|
||||
lib+abi3-py310.requires =
|
||||
python3-devel >= 3.10
|
Loading…
Reference in new issue