Update to version 0.19.2; Fixes RHBZ#2228010

epel10
Fabio Valentini 2 years ago
parent b3d9c2a5b6
commit 141b99a0a7
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -7,3 +7,4 @@
/pyo3-ffi-0.18.2.crate
/pyo3-ffi-0.18.3.crate
/pyo3-ffi-0.19.1.crate
/pyo3-ffi-0.19.2.crate

@ -1,26 +0,0 @@
From e07ffa586cf905f2c49eff3aea1b7fada38d5437 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Hrn=C4=8Diar?= <thrnciar@redhat.com>
Date: Tue, 25 Jul 2023 08:56:05 +0200
Subject: [PATCH] Add PyType_GetDict for Python 3.12
---
src/cpython/object.rs | 3 +++
1 file changed, 3 insertions(+)
diff --git a/src/cpython/object.rs b/src/cpython/object.rs
index 76ab074..8209524 100644
--- a/src/cpython/object.rs
+++ b/src/cpython/object.rs
@@ -349,6 +349,9 @@ pub unsafe fn PyHeapType_GET_MEMBERS(
// skipped _PyType_GetModuleByDef
extern "C" {
+ #[cfg(Py_3_12)]
+ pub fn PyType_GetDict(o: *mut PyTypeObject) -> *mut PyObject;
+
#[cfg_attr(PyPy, link_name = "PyPyObject_Print")]
pub fn PyObject_Print(o: *mut PyObject, fp: *mut ::libc::FILE, flags: c_int) -> c_int;
--
2.40.1

@ -1,5 +1,5 @@
--- pyo3-ffi-0.19.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pyo3-ffi-0.19.1/Cargo.toml 2023-07-05T16:53:34.873895+00:00
--- pyo3-ffi-0.19.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pyo3-ffi-0.19.2/Cargo.toml 2023-08-01T13:21:17.556533+00:00
@@ -62,4 +62,3 @@
]
default = []

@ -5,7 +5,7 @@
%global crate pyo3-ffi
Name: rust-pyo3-ffi
Version: 0.19.1
Version: 0.19.2
Release: %autorelease
Summary: Python-API bindings for the PyO3 ecosystem
@ -16,10 +16,6 @@ Source: %{crates_source}
# * drop MSVC- and MinGW-only features
Patch: pyo3-ffi-fix-metadata.diff
# Add PyType_GetDict for Python 3.12
# https://github.com/PyO3/pyo3/commit/8c393dd.patch
Patch: Add-PyType_GetDict-for-Python-3.12.patch
BuildRequires: rust-packaging >= 21
%global _description %{expand:

@ -1 +1 @@
SHA512 (pyo3-ffi-0.19.1.crate) = 6293d75c71ebe80c320f0a240716a2e0c62f66aecc58320f2f40a81f85390c7d9174b4888ead89818b73fdc8d3d21df12adc6625087f0c9ebb82767d4a7c5adc
SHA512 (pyo3-ffi-0.19.2.crate) = 789191bca537998dd23d72dce4f185b84bbe700f4171c47de35b9bbca15a180ad214392b4f465cc1ecb0be955ebec1cf5a3c497815073be18035bd8bf8c51a32

Loading…
Cancel
Save