commit
3faab3e953
Binary file not shown.
@ -0,0 +1,35 @@
|
||||
--- pulldown-cmark-0.8.0/Cargo.toml 2020-09-01T15:23:36+00:00
|
||||
+++ pulldown-cmark-0.8.0/Cargo.toml 2023-03-29T13:03:06.244787+00:00
|
||||
@@ -23,11 +23,7 @@
|
||||
categories = ["text-processing"]
|
||||
license = "MIT"
|
||||
repository = "https://github.com/raphlinus/pulldown-cmark"
|
||||
-
|
||||
-[[bin]]
|
||||
-name = "pulldown-cmark"
|
||||
-doc = false
|
||||
-required-features = ["getopts"]
|
||||
+autobins = false
|
||||
|
||||
[[bench]]
|
||||
name = "html_rendering"
|
||||
@@ -44,17 +40,15 @@
|
||||
|
||||
[dependencies.unicase]
|
||||
version = "2.6"
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3"
|
||||
|
||||
[dev-dependencies.html5ever]
|
||||
-version = "0.25"
|
||||
+version = "0.26"
|
||||
|
||||
[dev-dependencies.lazy_static]
|
||||
version = "1.4"
|
||||
|
||||
[dev-dependencies.markup5ever_rcdom]
|
||||
-version = "0.1"
|
||||
+version = "0.2"
|
||||
|
||||
[dev-dependencies.regex]
|
||||
version = "1.3"
|
@ -0,0 +1,131 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 3;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate pulldown-cmark
|
||||
|
||||
Name: rust-pulldown-cmark0.8
|
||||
Version: 0.8.0
|
||||
Release: %autorelease
|
||||
Summary: Pull parser for CommonMark
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/pulldown-cmark
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop pulldown-cmark binary from compat package
|
||||
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||
# * bump html5ever dev-dependency from 0.25 to 0.26
|
||||
# * bump markup5ever_rcdom dev-dependency from 0.1 to 0.2
|
||||
Patch: pulldown-cmark-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
A pull parser for CommonMark.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CONTRIBUTING.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+gen-tests-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+gen-tests-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "gen-tests" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+gen-tests-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+getopts-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+getopts-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "getopts" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+getopts-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+simd-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+simd-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "simd" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+simd-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.8.0-3
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Wed Mar 29 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.0-3
|
||||
- Bump html5ever to v0.26 and markup5ever_rcdom to v0.2
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Thu Dec 15 2022 Fabio Valentini <decathorpe@gmail.com> - 0.8.0-1
|
||||
- Initial import (pulldown-cmark 0.8 compat package)
|
Loading…
Reference in new issue