Initial package (rhbz#2219471)

epel9
blinxen 2 years ago
parent 3003d4e42e
commit 17ca3519f0

1
.gitignore vendored

@ -0,0 +1 @@
/prodash-25.0.0.crate

@ -1,3 +0,0 @@
# rust-prodash
The rust-prodash package

@ -0,0 +1,133 @@
--- prodash-25.0.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ prodash-25.0.0/Cargo.toml 2023-07-05T18:01:06.358818+00:00
@@ -31,44 +31,6 @@
[lib]
doctest = true
-[[example]]
-name = "dashboard"
-path = "examples/dashboard.rs"
-required-features = [
- "render-tui",
- "render-tui-crossterm",
- "render-line",
- "render-line-crossterm",
- "signal-hook",
- "render-line-autoconfigure",
- "progress-tree",
-]
-
-[[example]]
-name = "dashboard-termion"
-path = "examples/dashboard.rs"
-required-features = [
- "render-tui",
- "render-tui-termion",
- "render-line",
- "render-line-termion",
- "progress-tree",
-]
-
-[[example]]
-name = "units"
-path = "examples/units.rs"
-required-features = [
- "unit-bytes",
- "unit-duration",
- "unit-human",
- "render-tui",
- "render-tui-crossterm",
- "render-line",
- "render-line-crossterm",
- "signal-hook",
-]
-
[[bench]]
name = "usage"
path = "benches/usage.rs"
@@ -85,15 +47,6 @@
[dependencies.bytesize]
version = "1.0.1"
optional = true
-
-[dependencies.compound_duration]
-version = "1.2.0"
-optional = true
-
-[dependencies.crosstermion]
-version = "0.11.0"
-optional = true
-default-features = false
[dependencies.ctrlc]
version = "3.1.4"
@@ -113,10 +66,6 @@
[dependencies.futures-lite]
version = "1.5.0"
-optional = true
-
-[dependencies.human_format]
-version = "1.0.3"
optional = true
[dependencies.humantime]
@@ -147,16 +96,6 @@
optional = true
default-features = false
-[dependencies.tui]
-version = "0.20.1"
-optional = true
-default-features = false
-package = "ratatui"
-
-[dependencies.tui-react]
-version = "0.20.0"
-optional = true
-
[dependencies.unicode-segmentation]
version = "1.6.0"
optional = true
@@ -179,10 +118,6 @@
[dev-dependencies.blocking]
version = "1.0.0"
-
-[dev-dependencies.criterion]
-version = "0.4.0"
-default-features = false
[dev-dependencies.env_logger]
version = "0.10.0"
@@ -212,30 +147,5 @@
progress-tree = ["parking_lot"]
progress-tree-hp-hashmap = ["dashmap"]
progress-tree-log = ["log"]
-render-line = [
- "crosstermion/color",
- "humantime",
- "unicode-width",
-]
render-line-autoconfigure = ["atty"]
-render-line-crossterm = ["crosstermion/crossterm"]
-render-line-termion = ["crosstermion/termion"]
-render-tui = [
- "tui",
- "unicode-segmentation",
- "unicode-width",
- "crosstermion/input-async",
- "tui-react",
- "futures-lite",
- "futures-core",
- "async-io",
- "humantime",
-]
-render-tui-crossterm = [
- "crosstermion/tui-react-crossterm",
- "crosstermion/input-async-crossterm",
-]
-render-tui-termion = ["crosstermion/tui-react-termion"]
unit-bytes = ["bytesize"]
-unit-duration = ["compound_duration"]
-unit-human = ["human_format"]

@ -0,0 +1,326 @@
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate prodash
Name: rust-prodash
Version: 25.0.0
Release: %autorelease
Summary: Dashboard for visualizing progress of asynchronous and possibly blocking tasks
License: MIT
URL: https://crates.io/crates/prodash
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * Drop benchmark dependency
# * Drop optional features that don't build and are not reuquired at the moment
Patch: prodash-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
A dashboard for visualizing progress of asynchronous and possibly
blocking tasks.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE.md
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-io-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+async-io-devel %{_description}
This package contains library source intended for building other packages which
use the "async-io" feature of the "%{crate}" crate.
%files -n %{name}+async-io-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+atty-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+atty-devel %{_description}
This package contains library source intended for building other packages which
use the "atty" feature of the "%{crate}" crate.
%files -n %{name}+atty-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytesize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytesize-devel %{_description}
This package contains library source intended for building other packages which
use the "bytesize" feature of the "%{crate}" crate.
%files -n %{name}+bytesize-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ctrlc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ctrlc-devel %{_description}
This package contains library source intended for building other packages which
use the "ctrlc" feature of the "%{crate}" crate.
%files -n %{name}+ctrlc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dashmap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dashmap-devel %{_description}
This package contains library source intended for building other packages which
use the "dashmap" feature of the "%{crate}" crate.
%files -n %{name}+dashmap-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-core-devel %{_description}
This package contains library source intended for building other packages which
use the "futures-core" feature of the "%{crate}" crate.
%files -n %{name}+futures-core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-lite-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-lite-devel %{_description}
This package contains library source intended for building other packages which
use the "futures-lite" feature of the "%{crate}" crate.
%files -n %{name}+futures-lite-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+humantime-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+humantime-devel %{_description}
This package contains library source intended for building other packages which
use the "humantime" feature of the "%{crate}" crate.
%files -n %{name}+humantime-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+local-time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+local-time-devel %{_description}
This package contains library source intended for building other packages which
use the "local-time" feature of the "%{crate}" crate.
%files -n %{name}+local-time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages which
use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parking_lot-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parking_lot-devel %{_description}
This package contains library source intended for building other packages which
use the "parking_lot" feature of the "%{crate}" crate.
%files -n %{name}+parking_lot-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-log-devel %{_description}
This package contains library source intended for building other packages which
use the "progress-log" feature of the "%{crate}" crate.
%files -n %{name}+progress-log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-tree-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-tree-devel %{_description}
This package contains library source intended for building other packages which
use the "progress-tree" feature of the "%{crate}" crate.
%files -n %{name}+progress-tree-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-tree-hp-hashmap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-tree-hp-hashmap-devel %{_description}
This package contains library source intended for building other packages which
use the "progress-tree-hp-hashmap" feature of the "%{crate}" crate.
%files -n %{name}+progress-tree-hp-hashmap-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+progress-tree-log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+progress-tree-log-devel %{_description}
This package contains library source intended for building other packages which
use the "progress-tree-log" feature of the "%{crate}" crate.
%files -n %{name}+progress-tree-log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+render-line-autoconfigure-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+render-line-autoconfigure-devel %{_description}
This package contains library source intended for building other packages which
use the "render-line-autoconfigure" feature of the "%{crate}" crate.
%files -n %{name}+render-line-autoconfigure-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+signal-hook-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+signal-hook-devel %{_description}
This package contains library source intended for building other packages which
use the "signal-hook" feature of the "%{crate}" crate.
%files -n %{name}+signal-hook-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-segmentation-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-segmentation-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-segmentation" feature of the "%{crate}" crate.
%files -n %{name}+unicode-segmentation-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-width-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-width-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-width" feature of the "%{crate}" crate.
%files -n %{name}+unicode-width-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unit-bytes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unit-bytes-devel %{_description}
This package contains library source intended for building other packages which
use the "unit-bytes" feature of the "%{crate}" crate.
%files -n %{name}+unit-bytes-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (prodash-25.0.0.crate) = 62311957598e0abc8a60a114a5bebaaff5d14c1b7c6e3886c964449e9c3f796773c0760a4079e686e3d05d0c26f31a8f70888b9040e7f6a6d6b65fd329910d24
Loading…
Cancel
Save