Update to version 0.14.1; Fixes RHBZ#2242470

epel9 imports/e9/rust-procs-0.14.1-1.el9
Fabio Valentini 1 year ago
parent 876e50b98e
commit fbaae6aaa3
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -8,3 +8,4 @@
/procs-0.10.10.crate /procs-0.10.10.crate
/procs-0.12.3.crate /procs-0.12.3.crate
/procs-0.14.0.crate /procs-0.14.0.crate
/procs-0.14.1.crate

@ -1,17 +1,17 @@
--- procs-0.14.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- procs-0.14.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ procs-0.14.0/Cargo.toml 2023-08-02T12:35:27.569881+00:00 +++ procs-0.14.1/Cargo.toml 2023-10-07T10:12:15.779397+00:00
@@ -153,38 +153,6 @@ @@ -161,38 +161,6 @@
[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.which] [target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.which]
version = "4" version = "4"
-[target."cfg(target_os = \"macos\")".dependencies.errno] -[target."cfg(target_os = \"macos\")".dependencies.errno]
-version = "0.2" -version = "0.3"
- -
-[target."cfg(target_os = \"macos\")".dependencies.libproc] -[target."cfg(target_os = \"macos\")".dependencies.libproc]
-version = "0.13" -version = "0.14"
- -
-[target."cfg(target_os = \"macos\")".dependencies.nix] -[target."cfg(target_os = \"macos\")".dependencies.nix]
-version = "0.26.2" -version = "0.27.1"
-features = ["process"] -features = ["process"]
- -
-[target."cfg(target_os = \"macos\")".dependencies.pager] -[target."cfg(target_os = \"macos\")".dependencies.pager]
@ -39,3 +39,8 @@
[badges.codecov] [badges.codecov]
branch = "master" branch = "master"
repository = "dalance/procs" repository = "dalance/procs"
@@ -200,3 +168,4 @@
[badges.travis-ci]
repository = "dalance/procs"
+

@ -1,22 +1,25 @@
--- procs-0.14.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- procs-0.14.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ procs-0.14.0/Cargo.toml 2023-08-02T12:35:47.131968+00:00 +++ procs-0.14.1/Cargo.toml 2023-10-07T10:12:32.536030+00:00
@@ -102,10 +102,6 @@ @@ -102,10 +102,6 @@
[dependencies.directories] [dependencies.directories]
version = "4.0.1" version = "5.0.1"
-[dependencies.dockworker] -[dependencies.dockworker]
-version = "0.1.2" -version = "0.3.0"
-optional = true -optional = true
- -
[dependencies.getch] [dependencies.getch]
version = "0.3.1" version = "0.3.1"
@@ -138,8 +134,7 @@ @@ -143,11 +139,7 @@
version = "0.1" version = "0.1"
[features] [features]
-default = ["docker"] -default = ["docker"]
-docker = ["dockworker"] -docker = [
- "dockworker",
- "tokio",
-]
+default = [] +default = []
[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.pager] [target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies.pager]

@ -1,17 +1,17 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check %bcond_without check
%global crate procs %global crate procs
Name: rust-procs Name: rust-procs
Version: 0.14.0 Version: 0.14.1
Release: %autorelease Release: %autorelease
Summary: Modern replacement for ps Summary: Modern replacement for ps
License: MIT License: MIT
URL: https://crates.io/crates/procs URL: https://crates.io/crates/procs
Source: %{crates_source} Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip dependencies and normalize metadata
Patch: procs-fix-metadata-auto.diff Patch: procs-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * remove docker feature / dockworker dependency # * remove docker feature / dockworker dependency
@ -35,8 +35,9 @@ Summary: %{summary}
# MIT # MIT
# MIT OR Apache-2.0 # MIT OR Apache-2.0
# MIT OR Zlib OR Apache-2.0 # MIT OR Zlib OR Apache-2.0
# MPL-2.0
# Unlicense OR MIT # Unlicense OR MIT
License: Apache-2.0 AND BSD-3-Clause AND MIT AND Unicode-DFS-2016 AND (0BSD OR MIT OR Apache-2.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (MIT OR Zlib OR Apache-2.0) AND (Unlicense OR MIT) License: Apache-2.0 AND BSD-3-Clause AND MIT AND MPL-2.0 AND Unicode-DFS-2016 AND (0BSD OR MIT OR Apache-2.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (MIT OR Zlib OR Apache-2.0) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown # LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description} %description -n %{crate} %{_description}
@ -49,7 +50,7 @@ License: Apache-2.0 AND BSD-3-Clause AND MIT AND Unicode-DFS-2016 AND (0B
%{_bindir}/procs %{_bindir}/procs
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires
@ -57,7 +58,7 @@ License: Apache-2.0 AND BSD-3-Clause AND MIT AND Unicode-DFS-2016 AND (0B
%build %build
%cargo_build %cargo_build
%cargo_license_summary %{cargo_license_summary}
%{cargo_license} > LICENSE.dependencies %{cargo_license} > LICENSE.dependencies
%install %install

@ -1 +1 @@
SHA512 (procs-0.14.0.crate) = 8941b7fe6a6a1ce3ae0c771884c5516d907b4edc3f851238b9884adeb9a511de09b9720df468192f1d31c35fe592cce1afa4b64ed646989d97491a25c36054ac SHA512 (procs-0.14.1.crate) = d6c6abf9e5baf84a00c636598c17a4eb132888170a4c9ca67284c8ba0e1cc9a38b443e906d79106639c9abed0ca7532f1f6ab3100e5ad764726d20472fdce4c0

Loading…
Cancel
Save