Update to 0.4.11

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent 0d393fcfe2
commit 1be993a4d7
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -3,3 +3,4 @@
/proc-macro-error-0.4.8.crate
/proc-macro-error-0.4.9.crate
/proc-macro-error-0.4.10.crate
/proc-macro-error-0.4.11.crate

@ -1,36 +0,0 @@
From e7626a25471d2db29e7cdee81308ee4604b41544 Mon Sep 17 00:00:00 2001
From: Igor Raits <i.gnatenko.brain@gmail.com>
Date: Mon, 2 Mar 2020 12:14:11 +0100
Subject: [PATCH] build.rs: Simplify check for version
This also fixes build with rustc shipped by distributions.
Fixes: https://gitlab.com/CreepySkeleton/proc-macro-error/issues/8
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
---
build.rs | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/build.rs b/build.rs
index 17cf408..3c1196f 100644
--- a/build.rs
+++ b/build.rs
@@ -1,11 +1,11 @@
fn main() {
- let (version, channel, _) = version_check::triple().unwrap();
-
- if !channel.is_nightly() {
+ if !version_check::is_feature_flaggable().unwrap_or(false) {
println!("cargo:rustc-cfg=use_fallback");
}
- if version.at_most("1.38.0") || !channel.is_stable() {
+ if version_check::is_max_version("1.38.0").unwrap_or(false)
+ || !version_check::Channel::read().unwrap().is_stable()
+ {
println!("cargo:rustc-cfg=skip_ui_tests");
}
}
--
2.25.1

@ -1,5 +1,5 @@
--- proc-macro-error-0.4.10/Cargo.toml 2020-02-29T15:59:26+00:00
+++ proc-macro-error-0.4.10/Cargo.toml 2020-03-02T08:06:31.398597+00:00
--- proc-macro-error-0.4.11/Cargo.toml 2020-03-02T13:26:24+00:00
+++ proc-macro-error-0.4.11/Cargo.toml 2020-03-02T13:53:33.669480+00:00
@@ -36,7 +36,7 @@
features = ["derive", "parsing", "proc-macro", "printing"]
default-features = false

@ -6,7 +6,7 @@
%global crate proc-macro-error
Name: rust-%{crate}
Version: 0.4.10
Version: 0.4.11
Release: 1%{?dist}
Summary: Almost drop-in replacement to panics in proc-macros
@ -17,8 +17,6 @@ Source: %{crates_source}
# Initial patched metadata
# * unpin the toml dependency
Patch0: proc-macro-error-fix-metadata.diff
# https://gitlab.com/CreepySkeleton/proc-macro-error/-/merge_requests/25
Patch0001: 0001-build.rs-Simplify-check-for-version.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -77,6 +75,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Mon Mar 02 14:53:33 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.4.11-1
- Update to 0.4.11
* Mon Mar 02 09:06:31 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.4.10-1
- Update to 0.4.10

@ -1 +1 @@
SHA512 (proc-macro-error-0.4.10.crate) = a11ede5e08c62cefbbb7b1c7894593e923688ba10b1ff46907f8e34f69e3cd86f940604f0419206471991c4e70ba5c32e37ce41d1b0ab8b26b90a7f06a39c0e8
SHA512 (proc-macro-error-0.4.11.crate) = 8d6098bcb1b61bf6894feb10a447afb71f9862f83a0c00b2eee9b0443c77d9ad7e17f848d760c158f1070d3e6716e4490f1c31199800d72939749d71051681c6

Loading…
Cancel
Save