parent
31d1bb90bc
commit
0ab4569ee0
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/pretty_assertions-0.6.1.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-pretty_assertions0.6
|
||||
|
||||
The rust-pretty_assertions0.6 package
|
@ -0,0 +1,13 @@
|
||||
--- pretty_assertions-0.6.1/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ pretty_assertions-0.6.1/Cargo.toml 2019-02-23T10:49:56.328708+01:00
|
||||
@@ -27,10 +27,5 @@
|
||||
|
||||
[dependencies.difference]
|
||||
version = "2.0.0"
|
||||
-[target."cfg(windows)".dependencies.ctor]
|
||||
-version = "0.1.7"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.output_vt100]
|
||||
-version = "0.1.2"
|
||||
[badges.travis-ci]
|
||||
repository = "colin-kiegel/rust-pretty-assertions"
|
@ -0,0 +1,80 @@
|
||||
# Generated by rust2rpm 17
|
||||
# * tests fail with cosmetic string differences
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate pretty_assertions
|
||||
|
||||
Name: rust-%{crate}0.6
|
||||
Version: 0.6.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Overwrite assert_eq! and assert_ne! with colorful replacements
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/pretty_assertions
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * drop windows-specific dependencies
|
||||
Patch0: pretty_assertions-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Overwrite `assert_eq!` and `assert_ne!` with drop-in replacements, adding
|
||||
colorful diffs.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-APACHE LICENSE-MIT
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Apr 20 2021 Fabio Valentini <decathorpe@gmail.com> - 0.6.1-1
|
||||
- Initial compat package for pretty_assertions 0.6
|
Loading…
Reference in new issue