import rust-portable-atomic-1.10.0-1.el10

i10ce changed/i10ce/rust-portable-atomic-1.10.0-1.el10
MSVSphere Packaging Team 4 weeks ago
commit 758e2d891c
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/portable-atomic-1.10.0.crate

@ -0,0 +1 @@
2622a4742e89f9b584003cc049dff6e3b3622c19 SOURCES/portable-atomic-1.10.0.crate

@ -0,0 +1,21 @@
--- portable-atomic-1.10.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ portable-atomic-1.10.0/Cargo.toml 2024-11-26T14:44:15.627256+00:00
@@ -98,13 +98,6 @@
[target."cfg(unix)".dev-dependencies.libc]
version = "=0.2.163"
-[target."cfg(windows)".dev-dependencies.windows-sys]
-version = "0.59"
-features = [
- "Win32_Foundation",
- "Win32_System_Threading",
-]
-
[lints.clippy]
all = "warn"
as_ptr_cast_mut = "warn"
@@ -236,3 +229,4 @@
"cfg(portable_atomic_no_outline_atomics,portable_atomic_outline_atomics)",
"cfg(portable_atomic_unstable_coerce_unsized)",
]
+

@ -0,0 +1,4 @@
[tests]
run = ["none"]
comments = ["tests can only be run in-tree"]

@ -0,0 +1,258 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 27
# * tests can only be run in-tree
%bcond check 0
%global debug_package %{nil}
%global crate portable-atomic
Name: rust-portable-atomic
Version: 1.10.0
Release: %autorelease
Summary: Portable atomic types including support for 128-bit atomics, atomic float, etc
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/portable-atomic
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: portable-atomic-fix-metadata-auto.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Portable atomic types including support for 128-bit atomics, atomic
float, etc.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+critical-section-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+critical-section-devel %{_description}
This package contains library source intended for building other packages which
use the "critical-section" feature of the "%{crate}" crate.
%files -n %{name}+critical-section-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+disable-fiq-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+disable-fiq-devel %{_description}
This package contains library source intended for building other packages which
use the "disable-fiq" feature of the "%{crate}" crate.
%files -n %{name}+disable-fiq-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fallback-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fallback-devel %{_description}
This package contains library source intended for building other packages which
use the "fallback" feature of the "%{crate}" crate.
%files -n %{name}+fallback-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+float-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+float-devel %{_description}
This package contains library source intended for building other packages which
use the "float" feature of the "%{crate}" crate.
%files -n %{name}+float-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+force-amo-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+force-amo-devel %{_description}
This package contains library source intended for building other packages which
use the "force-amo" feature of the "%{crate}" crate.
%files -n %{name}+force-amo-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+require-cas-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+require-cas-devel %{_description}
This package contains library source intended for building other packages which
use the "require-cas" feature of the "%{crate}" crate.
%files -n %{name}+require-cas-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+s-mode-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+s-mode-devel %{_description}
This package contains library source intended for building other packages which
use the "s-mode" feature of the "%{crate}" crate.
%files -n %{name}+s-mode-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unsafe-assume-single-core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unsafe-assume-single-core-devel %{_description}
This package contains library source intended for building other packages which
use the "unsafe-assume-single-core" feature of the "%{crate}" crate.
%files -n %{name}+unsafe-assume-single-core-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.10.0-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Tue Nov 26 2024 Fabio Valentini <decathorpe@gmail.com> - 1.10.0-1
- Update to version 1.10.0; Fixes RHBZ#2328513
* Sat Oct 05 2024 Fabio Valentini <decathorpe@gmail.com> - 1.9.0-1
- Update to version 1.9.0; Fixes RHBZ#2313798
* Fri Aug 09 2024 Fabio Valentini <decathorpe@gmail.com> - 1.7.0-1
- Update to version 1.7.0; Fixes RHBZ#2298929
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Thu Jan 11 2024 Fabio Valentini <decathorpe@gmail.com> - 1.6.0-1
- Update to version 1.6.0; Fixes RHBZ#2253112
* Mon Nov 13 2023 Fabio Valentini <decathorpe@gmail.com> - 1.5.1-1
- Update to version 1.5.1; Fixes RHBZ#2246855
* Tue Oct 24 2023 Fabio Valentini <decathorpe@gmail.com> - 1.5.0-1
- Update to version 1.5.0; Fixes RHBZ#2245708
* Sat Aug 26 2023 Fabio Valentini <decathorpe@gmail.com> - 1.4.3-1
- Update to version 1.4.3; Fixes RHBZ#2234893
* Tue Aug 01 2023 Fabio Valentini <decathorpe@gmail.com> - 1.4.2-1
- Update to version 1.4.2; Fixes RHBZ#2227102
* Fri Jul 21 2023 Fabio Valentini <decathorpe@gmail.com> - 1.4.1-1
- Update to version 1.4.1; Fixes RHBZ#2223114
* Wed Jul 12 2023 Fabio Valentini <decathorpe@gmail.com> - 1.4.0-1
- Update to version 1.4.0; Fixes RHBZ#2222097
* Wed Jun 07 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.3-1
- Update to version 1.3.3; Fixes RHBZ#2211250
* Wed May 17 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.2-1
- Update to version 1.3.2; Fixes RHBZ#2196654
* Mon May 08 2023 Fabio Valentini <decathorpe@gmail.com> - 1.3.1-1
- Update to version 1.3.1; Fixes RHBZ#2195953
* Sun Mar 26 2023 Fabio Valentini <decathorpe@gmail.com> - 1.2.0-1
- Update to version 1.2.0
* Fri Jan 20 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 1.0.0-1
- Initial Fedora package
## END: Generated by rpmautospec
Loading…
Cancel
Save