Initial import (polling 2 compat package)

epel9 imports/e9/rust-polling2-2.8.0-1.el9
Fabio Valentini 1 year ago
parent c518434219
commit f3d54016c3
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/polling-2.8.0.crate

@ -1,3 +0,0 @@
# rust-polling2
The rust-polling2 package

@ -0,0 +1,26 @@
--- polling-2.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ polling-2.8.0/Cargo.toml 2023-11-21T18:44:43.652491+00:00
@@ -60,23 +60,3 @@
[target."cfg(any(unix, target_os = \"fuchsia\", target_os = \"vxworks\"))".dependencies.libc]
version = "0.2.77"
-[target."cfg(windows)".dependencies.bitflags]
-version = "1.3.2"
-
-[target."cfg(windows)".dependencies.concurrent-queue]
-version = "2.2.0"
-
-[target."cfg(windows)".dependencies.pin-project-lite]
-version = "0.2.9"
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.48"
-features = [
- "Win32_Foundation",
- "Win32_Networking_WinSock",
- "Win32_Storage_FileSystem",
- "Win32_System_IO",
- "Win32_System_LibraryLoader",
- "Win32_System_Threading",
- "Win32_System_WindowsProgramming",
-]

@ -0,0 +1,84 @@
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate polling
Name: rust-polling2
Version: 2.8.0
Release: %autorelease
Summary: Portable interface to epoll, kqueue, event ports, and IOCP
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/polling
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: polling-fix-metadata-auto.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Portable interface to epoll, kqueue, event ports, and IOCP.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (polling-2.8.0.crate) = c22dc35f39f374f21483c987d43108472dbfc291508e3f5e1d76e2c466f40b396b1ba7c222db5e5a2c0e670e83b4c34e0fbb5c3e93d86435b8a2ebb0890471a2
Loading…
Cancel
Save