Revert "Update to 0.5.3"

Depends on humantime 2.x which is not packaged yet.

This reverts commit cee36075d5.

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent cee36075d5
commit 135a8de59f
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -2,4 +2,3 @@
/plist-0.4.1.crate /plist-0.4.1.crate
/plist-0.4.2.crate /plist-0.4.2.crate
/plist-0.5.1.crate /plist-0.5.1.crate
/plist-0.5.3.crate

@ -0,0 +1,43 @@
From 2b984085425549496b365255e807d1b45ac57e69 Mon Sep 17 00:00:00 2001
From: Josh Stone <cuviper@gmail.com>
Date: Thu, 16 Jan 2020 12:52:53 -0800
Subject: [PATCH 1/2] Make sure offset_table_offset is written as 8 bytes
It's a `usize` value, but the output format expects 8 bytes. That's fine
on 64-bit targets, but 32-bit targets were failing tests:
---- stream::binary_writer::tests::bplist_roundtrip stdout ----
thread 'stream::binary_writer::tests::bplist_roundtrip' panicked at 'assertion failed: `(left == right)`
left: `8`,
right: `4`: destination and source slices have different lengths', src/libcore/slice/mod.rs:2217:9
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace.
---- stream::binary_writer::tests::nskeyedarchiver_roundtrip stdout ----
thread 'stream::binary_writer::tests::nskeyedarchiver_roundtrip' panicked at 'assertion failed: `(left == right)`
left: `8`,
right: `4`: destination and source slices have different lengths', src/libcore/slice/mod.rs:2217:9
---- stream::binary_writer::tests::utf16_roundtrip stdout ----
thread 'stream::binary_writer::tests::utf16_roundtrip' panicked at 'assertion failed: `(left == right)`
left: `8`,
right: `4`: destination and source slices have different lengths', src/libcore/slice/mod.rs:2217:9
Casting to `u64` makes sure we have the correct size to write.
---
src/stream/binary_writer.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/stream/binary_writer.rs b/src/stream/binary_writer.rs
index 6541ea8d09d5..fe1e0902cda8 100644
--- a/src/stream/binary_writer.rs
+++ b/src/stream/binary_writer.rs
@@ -335,7 +335,7 @@ impl<W: Write> BinaryWriter<W> {
trailer[6] = offset_size;
trailer[7] = ref_size;
trailer[8..16].copy_from_slice(&(self.num_objects as u64).to_be_bytes());
- trailer[24..32].copy_from_slice(&offset_table_offset.to_be_bytes());
+ trailer[24..32].copy_from_slice(&(offset_table_offset as u64).to_be_bytes());
self.writer.write_exact(&trailer)?;
self.writer
--
2.24.1

@ -5,8 +5,8 @@
%global crate plist %global crate plist
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.5.3 Version: 0.5.1
Release: 1%{?dist} Release: 2%{?dist}
Summary: Rusty plist parser Summary: Rusty plist parser
# Upstream license specification: MIT # Upstream license specification: MIT
@ -14,6 +14,9 @@ License: MIT
URL: https://crates.io/crates/plist URL: https://crates.io/crates/plist
Source: %{crates_source} Source: %{crates_source}
# Fix for 32-bit targets, https://github.com/ebarnard/rust-plist/pull/47
Patch1: 0001-Make-sure-offset_table_offset-is-written-as-8-bytes.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
BuildArch: noarch BuildArch: noarch
@ -52,18 +55,6 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+enable_unstable_features_that_may_break_with_minor_version_bumps-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+enable_unstable_features_that_may_break_with_minor_version_bumps-devel %{_description}
This package contains library source intended for building other packages
which use "enable_unstable_features_that_may_break_with_minor_version_bumps" feature of "%{crate}" crate.
%files -n %{name}+enable_unstable_features_that_may_break_with_minor_version_bumps-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -95,9 +86,6 @@ which use "serde" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Tue Feb 11 10:02:36 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.5.3-1
- Update to 0.5.3
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-2 * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (plist-0.5.3.crate) = 027668a043c8ae53e9be5ad22cc7e7a8674757f8dd6b79ce10c04d276e9d4dff26bd9995baa315c87982abee47611e5368ad6c65e3a1e3fb3231614da9c1402d SHA512 (plist-0.5.1.crate) = 46ee6109bdff92a68c886a0751fedb149d760e38e07469cd507ca5ff17c463e460ae0b377e53bd412becf17ae74df09ccc67713800f09d4b3aa41ed5978a8dd3

Loading…
Cancel
Save