commit
349be9c946
Binary file not shown.
@ -0,0 +1,25 @@
|
||||
--- piper-0.2.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ piper-0.2.1/Cargo.toml 2023-10-08T21:09:34.238288+00:00
|
||||
@@ -22,10 +22,6 @@
|
||||
readme = "README.md"
|
||||
license = "MIT OR Apache-2.0"
|
||||
repository = "https://github.com/notgull/piper"
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "pipe_comparison"
|
||||
-harness = false
|
||||
|
||||
[dependencies.atomic-waker]
|
||||
version = "1.1.0"
|
||||
@@ -58,11 +54,6 @@
|
||||
[dev-dependencies.async-io]
|
||||
version = "1.13.0"
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.4.0"
|
||||
-features = ["cargo_bench_support"]
|
||||
-default-features = false
|
||||
-
|
||||
[dev-dependencies.easy-parallel]
|
||||
version = "3.2.0"
|
||||
|
@ -0,0 +1,169 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate piper
|
||||
|
||||
Name: rust-piper
|
||||
Version: 0.2.1
|
||||
Release: %autorelease
|
||||
Summary: Async pipes, channels, mutexes, and more
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/piper
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency
|
||||
Patch: piper-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Async pipes, channels, mutexes, and more.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+futures-io-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+futures-io-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "futures-io" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+futures-io-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+portable-atomic-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+portable-atomic-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "portable-atomic" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+portable-atomic-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+portable-atomic-util-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+portable-atomic-util-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "portable-atomic-util" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+portable-atomic-util-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+portable_atomic_crate-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+portable_atomic_crate-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "portable_atomic_crate" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+portable_atomic_crate-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.2.1-1
|
||||
- Rebuilt for MSVSphere 9.2
|
||||
|
||||
* Mon Nov 06 2023 Fabio Valentini <decathorpe@gmail.com> - 0.2.1-1
|
||||
- Update to version 0.2.1
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.3-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jun 10 2020 Josh Stone <jistone@redhat.com> - 0.1.3-1
|
||||
- Update to 0.1.3
|
||||
|
||||
* Sun May 24 08:03:54 CEST 2020 Igor Raits <i.gnatenko.brain@gmail.com> - 0.1.2-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue