parent
a12f8ca185
commit
8a8a23e26a
@ -1,47 +0,0 @@
|
|||||||
From 6c30f50f02209070090849e9f0d996353280361b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Steven Fackler <sfackler@gmail.com>
|
|
||||||
Date: Sat, 13 Jan 2018 15:41:15 -0800
|
|
||||||
Subject: [PATCH] Remove unicase support
|
|
||||||
|
|
||||||
It's out of date, and was only added for Servo which no longer uses it.
|
|
||||||
|
|
||||||
Closes #113
|
|
||||||
Closes #109
|
|
||||||
Closes #114
|
|
||||||
---
|
|
||||||
phf_shared/src/lib.rs | 12 ------------
|
|
||||||
1 file changed, 12 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/phf_shared/src/lib.rs b/phf_shared/src/lib.rs
|
|
||||||
index 7656c69..43074fd 100644
|
|
||||||
--- a/phf_shared/src/lib.rs
|
|
||||||
+++ b/phf_shared/src/lib.rs
|
|
||||||
@@ -6,9 +6,6 @@ extern crate std as core;
|
|
||||||
|
|
||||||
extern crate siphasher;
|
|
||||||
|
|
||||||
-#[cfg(feature = "unicase")]
|
|
||||||
-extern crate unicase;
|
|
||||||
-
|
|
||||||
use core::hash::{Hasher, Hash};
|
|
||||||
use siphasher::sip::SipHasher13;
|
|
||||||
|
|
||||||
@@ -110,15 +107,6 @@ impl PhfHash for [u8] {
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
-#[cfg(feature = "unicase")]
|
|
||||||
-impl<S> PhfHash for unicase::UniCase<S>
|
|
||||||
-where unicase::UniCase<S>: Hash {
|
|
||||||
- #[inline]
|
|
||||||
- fn phf_hash<H: Hasher>(&self, state: &mut H) {
|
|
||||||
- self.hash(state)
|
|
||||||
- }
|
|
||||||
-}
|
|
||||||
-
|
|
||||||
macro_rules! sip_impl(
|
|
||||||
(le $t:ty) => (
|
|
||||||
impl PhfHash for $t {
|
|
||||||
--
|
|
||||||
2.16.1
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
--- phf_shared-0.7.22/Cargo.toml 1969-12-31T16:00:00-08:00
|
|
||||||
+++ phf_shared-0.7.22/Cargo.toml 2018-05-02T14:15:06.534053-07:00
|
|
||||||
@@ -26,9 +26,5 @@
|
|
||||||
[dependencies.siphasher]
|
|
||||||
version = "0.2"
|
|
||||||
|
|
||||||
-[dependencies.unicase]
|
|
||||||
-version = "1.4"
|
|
||||||
-optional = true
|
|
||||||
-
|
|
||||||
[features]
|
|
||||||
core = []
|
|
Loading…
Reference in new issue