commit
d15e1226cd
Binary file not shown.
@ -0,0 +1,27 @@
|
|||||||
|
--- phf_generator-0.8.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ phf_generator-0.8.0/Cargo.toml 2023-03-12T21:55:11.559377+00:00
|
||||||
|
@@ -18,17 +18,7 @@
|
||||||
|
description = "PHF generation logic"
|
||||||
|
license = "MIT"
|
||||||
|
repository = "https://github.com/sfackler/rust-phf"
|
||||||
|
-
|
||||||
|
-[[bin]]
|
||||||
|
-name = "gen_hash_test"
|
||||||
|
-required-features = ["criterion"]
|
||||||
|
-
|
||||||
|
-[[bench]]
|
||||||
|
-name = "benches"
|
||||||
|
-harness = false
|
||||||
|
-[dependencies.criterion]
|
||||||
|
-version = "0.3"
|
||||||
|
-optional = true
|
||||||
|
+autobins = false
|
||||||
|
|
||||||
|
[dependencies.phf_shared]
|
||||||
|
version = "0.8.0"
|
||||||
|
@@ -36,5 +26,3 @@
|
||||||
|
[dependencies.rand]
|
||||||
|
version = "0.7"
|
||||||
|
features = ["small_rng"]
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "0.3"
|
@ -0,0 +1,97 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 5;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate phf_generator
|
||||||
|
|
||||||
|
Name: rust-phf_generator0.8
|
||||||
|
Version: 0.8.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: PHF generation logic
|
||||||
|
|
||||||
|
# https://github.com/sfackler/rust-phf/pull/118
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/phf_generator
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||||
|
# * drop unused binaries
|
||||||
|
Patch: phf_generator-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
PHF generation logic.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.8.0-5
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Sun Mar 12 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.0-5
|
||||||
|
- Regenerate with rust2rpm v24
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Nov 04 2022 Fabio Valentini <decathorpe@gmail.com> - 0.8.0-3
|
||||||
|
- Drop unused, benchmark-only criterion dev-dependency
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Feb 13 2022 Igor Raits <igor.raits@gmail.com> - 0.8.0-1
|
||||||
|
- Initial import
|
Loading…
Reference in new issue