Drop unused, benchmark-only criterion dev-dependency

epel9
Fabio Valentini 2 years ago
parent 1774209858
commit edd6f18d66
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,17 +1,27 @@
--- phf_generator-0.10.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ phf_generator-0.10.0/Cargo.toml 2022-02-13T14:51:17.931764+00:00
@@ -26,7 +26,7 @@
+++ phf_generator-0.10.0/Cargo.toml 2022-11-04T20:10:21.659206+00:00
@@ -17,17 +17,11 @@
description = "PHF generation logic"
license = "MIT"
repository = "https://github.com/sfackler/rust-phf"
-
-[[bin]]
-name = "gen_hash_test"
-required-features = ["criterion"]
+autobins = false
[[bench]]
name = "benches"
harness = false
[dependencies.criterion]
-[dependencies.criterion]
-version = "=0.3.4"
+version = "0.3"
optional = true
-optional = true
[dependencies.phf_shared]
@@ -37,4 +37,4 @@
version = "0.10.0"
@@ -36,5 +30,3 @@
[dependencies.rand]
version = "0.8"
features = ["small_rng"]
[dev-dependencies.criterion]
-[dev-dependencies.criterion]
-version = "=0.3.4"
+version = "0.3"

@ -1,29 +1,24 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}
# Binary is useless
%global __cargo_is_bin() false
%global crate phf_generator
Name: rust-%{crate}
Name: rust-phf_generator
Version: 0.10.0
Release: %autorelease
Summary: PHF generation logic
# Upstream license specification: MIT
# https://github.com/sfackler/rust-phf/pull/118
License: MIT
URL: https://crates.io/crates/phf_generator
Source: %{crates_source}
# Initial patched metadata
# * Unpin criterion (we don't promise MSRV)
Patch0: phf_generator-fix-metadata.diff
ExclusiveArch: %{rust_arches}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop unused binaries
Patch: phf_generator-fix-metadata.diff
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
PHF generation logic.}
@ -40,7 +35,7 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -52,19 +47,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+criterion-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+criterion-devel %{_description}
This package contains library source intended for building other packages which
use the "criterion" feature of the "%{crate}" crate.
%files -n %{name}+criterion-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

Loading…
Cancel
Save