parent
492985abef
commit
7829f2033d
@ -0,0 +1 @@
|
||||
/phf_codegen-0.7.21.crate
|
@ -0,0 +1,10 @@
|
||||
--- phf_codegen-0.7.21/Cargo.toml 2017-01-19T09:16:46+01:00
|
||||
+++ phf_codegen-0.7.21/Cargo.toml 2018-01-24T15:06:37.893065+01:00
|
||||
@@ -8,5 +8,5 @@
|
||||
documentation = "https://docs.rs/phf_codegen/0.7.21/phf_codegen"
|
||||
|
||||
[dependencies]
|
||||
-phf_generator = { version = "=0.7.21", path = "../phf_generator" }
|
||||
-phf_shared = { version = "=0.7.21", path = "../phf_shared" }
|
||||
+phf_generator = "=0.7.21"
|
||||
+phf_shared = "=0.7.21"
|
@ -0,0 +1,60 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate phf_codegen
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.7.21
|
||||
Release: 1%{?dist}
|
||||
Summary: Codegen library for PHF types
|
||||
|
||||
# https://github.com/sfackler/rust-phf/pull/118
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/phf_codegen
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No paths
|
||||
Patch0: phf_codegen-0.7.21-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: crate(phf_generator) = 0.7.21
|
||||
BuildRequires: crate(phf_shared) = 0.7.21
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Codegen library for PHF types.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Wed Jan 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.21-1
|
||||
- Initial package
|
Loading…
Reference in new issue