Do not pull optional dependencies

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent e438616c19
commit 9f861b30d9
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,17 +0,0 @@
--- phf-0.7.24/Cargo.toml 1970-01-01T01:00:00+01:00
+++ phf-0.7.24/Cargo.toml 2019-01-26T11:02:04.184134+01:00
@@ -22,14 +22,9 @@
name = "phf"
path = "src/lib.rs"
test = false
-[dependencies.phf_macros]
-version = "0.7.24"
-optional = true
-
[dependencies.phf_shared]
version = "0.7.24"
[features]
core = ["phf_shared/core"]
-macros = ["phf_macros"]
unicase = ["phf_shared/unicase"]

@ -7,23 +7,18 @@
Name: rust-%{crate}
Version: 0.7.24
Release: 3%{?dist}
Release: 4%{?dist}
Summary: Runtime support for perfect hash function data structures
# https://github.com/sfackler/rust-phf/pull/118
License: MIT
URL: https://crates.io/crates/phf
Source: %{crates_source}
# Initial patched metadata
# * Remove macros feature, as phf_macros is nightly only
Patch0: phf-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(phf_shared/core) >= 0.7.24 with crate(phf_shared/core) < 0.8.0)
BuildRequires: (crate(phf_shared/default) >= 0.7.24 with crate(phf_shared/default) < 0.8.0)
BuildRequires: (crate(phf_shared/unicase) >= 0.7.24 with crate(phf_shared/unicase) < 0.8.0)
%global _description \
Runtime support for perfect hash function data structures.
@ -79,7 +74,7 @@ which use "unicase" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
@ -94,6 +89,9 @@ which use "unicase" feature of "%{crate}" crate.
%endif
%changelog
* Thu Mar 14 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.24-4
- Do not pull optional dependencies
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.24-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-phf
Loading…
Cancel
Save