Add unicase feature back

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 3180405c32
commit 14b5bd5560
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,5 +1,5 @@
--- phf-0.7.24/Cargo.toml 1969-12-31T16:00:00-08:00
+++ phf-0.7.24/Cargo.toml 2019-01-07T22:33:59.562483-08:00
--- phf-0.7.24/Cargo.toml 1970-01-01T01:00:00+01:00
+++ phf-0.7.24/Cargo.toml 2019-01-26T11:02:04.184134+01:00
@@ -22,14 +22,9 @@
name = "phf"
path = "src/lib.rs"
@ -7,11 +7,11 @@
-[dependencies.phf_macros]
-version = "0.7.24"
-optional = true
-
[dependencies.phf_shared]
version = "0.7.24"
[features]
core = ["phf_shared/core"]
-macros = ["phf_macros"]
-unicase = ["phf_shared/unicase"]
unicase = ["phf_shared/unicase"]

@ -7,16 +7,15 @@
Name: rust-%{crate}
Version: 0.7.24
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Runtime support for perfect hash function data structures
# https://github.com/sfackler/rust-phf/pull/118
License: MIT
URL: https://crates.io/crates/phf
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
Source: %{crates_source}
# Initial patched metadata
# * Remove macros feature, as phf_macros is nightly only
# * Remove unicase feature, https://github.com/sfackler/rust-phf/pull/117
Patch0: phf-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -24,6 +23,7 @@ ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(phf_shared/core) >= 0.7.24 with crate(phf_shared/core) < 0.8.0)
BuildRequires: (crate(phf_shared/default) >= 0.7.24 with crate(phf_shared/default) < 0.8.0)
BuildRequires: (crate(phf_shared/unicase) >= 0.7.24 with crate(phf_shared/unicase) < 0.8.0)
%global _description \
Runtime support for perfect hash function data structures.
@ -66,6 +66,18 @@ which use "core" feature of "%{crate}" crate.
%files -n %{name}+core-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+unicase-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicase-devel %{_description}
This package contains library source intended for building other packages
which use "unicase" feature of "%{crate}" crate.
%files -n %{name}+unicase-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
@ -82,6 +94,9 @@ which use "core" feature of "%{crate}" crate.
%endif
%changelog
* Sat Jan 26 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.24-2
- Add unicase feature back
* Tue Jan 08 2019 Josh Stone <jistone@redhat.com> - 0.7.24-1
- Update to 0.7.24

Loading…
Cancel
Save