parent
a2243fc856
commit
e39d9f3b73
@ -0,0 +1 @@
|
||||
/pem-0.8.1.crate
|
@ -0,0 +1,10 @@
|
||||
--- pem-0.8.1/Cargo.toml 2020-06-08T14:01:44+00:00
|
||||
+++ pem-0.8.1/Cargo.toml 2020-06-25T07:55:32.739881+00:00
|
||||
@@ -35,6 +35,6 @@
|
||||
[dependencies.regex]
|
||||
version = "1"
|
||||
[dev-dependencies.criterion]
|
||||
-version = "0.2.3"
|
||||
+version = "0.3.0"
|
||||
[badges.travis-ci]
|
||||
repository = "jcreekmore/pem-rs"
|
@ -0,0 +1,80 @@
|
||||
# Generated by rust2rpm 13
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate pem
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.8.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Parse and encode PEM-encoded data
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/pem
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * https://github.com/jcreekmore/pem-rs/pull/24
|
||||
# * Bump deps
|
||||
# - criterion to 0.3.0
|
||||
Patch0: pem-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Parse and encode PEM-encoded data.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE.md
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jun 25 10:55:33 EEST 2020 Artem Polishchuk <ego.cordatus@gmail.com> - 0.8.1-1
|
||||
- Initial package
|
Loading…
Reference in new issue