Initial import (#2031927)
parent
bf8bdde91f
commit
7bb135833b
@ -0,0 +1,4 @@
|
|||||||
|
/results_*/
|
||||||
|
/*.src.rpm
|
||||||
|
|
||||||
|
/pem-rfc7468-0.2.4.crate
|
@ -0,0 +1,11 @@
|
|||||||
|
--- pem-rfc7468-0.2.4/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ pem-rfc7468-0.2.4/Cargo.toml 2021-12-13T17:29:09.108238+00:00
|
||||||
|
@@ -25,7 +25,7 @@
|
||||||
|
all-features = true
|
||||||
|
rustdoc-args = ["--cfg", "docsrs"]
|
||||||
|
[dependencies.base64ct]
|
||||||
|
-version = ">=1, <1.2"
|
||||||
|
+version = "1"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
alloc = []
|
@ -0,0 +1,102 @@
|
|||||||
|
# Generated by rust2rpm 20
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate pem-rfc7468
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.2.4
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: PEM Encoding (RFC 7468) for PKIX, PKCS, and CMS Structures
|
||||||
|
|
||||||
|
# Upstream license specification: Apache-2.0 OR MIT
|
||||||
|
License: ASL 2.0 or MIT
|
||||||
|
URL: https://crates.io/crates/pem-rfc7468
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * relax base64ct dependency (MSRV is irrelevant in Fedora)
|
||||||
|
Patch0: pem-rfc7468-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
PEM Encoding (RFC 7468) for PKIX, PKCS, and CMS Structures, implementing a
|
||||||
|
strict subset of the original Privacy-Enhanced Mail encoding intended
|
||||||
|
specifically for use with cryptographic keys, certificates, and other messages.
|
||||||
|
Provides a no_std-friendly, constant-time implementation suitable for use with
|
||||||
|
cryptographic private keys.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-APACHE LICENSE-MIT
|
||||||
|
%doc CHANGELOG.md README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+alloc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+alloc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "alloc" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+alloc-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue