parent
4e88637d34
commit
5ef5d9d0d0
@ -0,0 +1 @@
|
||||
/peg-macros-0.6.3.crate
|
@ -0,0 +1,25 @@
|
||||
Copyright (C) 2013 Kevin Mehall
|
||||
|
||||
Permission is hereby granted, free of charge, to any
|
||||
person obtaining a copy of this software and associated
|
||||
documentation files (the "Software"), to deal in the
|
||||
Software without restriction, including without
|
||||
limitation the rights to use, copy, modify, merge,
|
||||
publish, distribute, sublicense, and/or sell copies of
|
||||
the Software, and to permit persons to whom the Software
|
||||
is furnished to do so, subject to the following
|
||||
conditions:
|
||||
|
||||
The above copyright notice and this permission notice
|
||||
shall be included in all copies or substantial portions
|
||||
of the Software.
|
||||
|
||||
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
|
||||
ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
|
||||
TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
|
||||
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
|
||||
SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
|
||||
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
|
||||
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
|
||||
IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
|
||||
DEALINGS IN THE SOFTWARE.
|
@ -0,0 +1,14 @@
|
||||
--- peg-macros-0.6.3/Cargo.toml 2020-07-22T03:04:04+00:00
|
||||
+++ peg-macros-0.6.3/Cargo.toml 2023-09-09T17:20:12.018191+00:00
|
||||
@@ -24,11 +24,6 @@
|
||||
path = "lib.rs"
|
||||
proc-macro = true
|
||||
|
||||
-[[bin]]
|
||||
-name = "rust-peg"
|
||||
-path = "bin.rs"
|
||||
-test = false
|
||||
-bench = false
|
||||
[dependencies.peg-runtime]
|
||||
version = "= 0.6.3"
|
||||
|
@ -0,0 +1,86 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate peg-macros
|
||||
|
||||
Name: rust-peg-macros0.6
|
||||
Version: 0.6.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Procedural macros for rust-peg
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/peg-macros
|
||||
Source0: %{crates_source}
|
||||
# https://github.com/kevinmehall/rust-peg/pull/241
|
||||
Source1: https://github.com/kevinmehall/rust-peg/raw/%{version}/LICENSE
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop binary which is only useful for upstream development
|
||||
Patch: peg-macros-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Procedural macros for rust-peg. To use rust-peg, see the `peg` crate.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+trace-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+trace-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "trace" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+trace-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
cp -pav %{SOURCE1} .
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Sep 09 2023 Fabio Valentini <decathorpe@gmail.com> - 0.6.3-1
|
||||
- Initial package
|
Loading…
Reference in new issue