commit
861c0b3eea
Binary file not shown.
@ -0,0 +1,8 @@
|
||||
--- path-absolutize-3.1.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ path-absolutize-3.1.1/Cargo.toml 2023-09-09T17:40:57.965698+00:00
|
||||
@@ -55,5 +55,3 @@
|
||||
unsafe_cache = ["path-dedot/unsafe_cache"]
|
||||
use_unix_paths_on_wasm = ["path-dedot/use_unix_paths_on_wasm"]
|
||||
|
||||
-[target."cfg(windows)".dev-dependencies.slash-formatter]
|
||||
-version = "3"
|
@ -0,0 +1,193 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate path-absolutize
|
||||
|
||||
Name: rust-path-absolutize
|
||||
Version: 3.1.1
|
||||
Release: %autorelease
|
||||
Summary: Extend Path and PathBuf for getting an absolute path
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/path-absolutize
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: path-absolutize-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
A library for extending `Path` and `PathBuf` in order to get an absolute
|
||||
path and remove the containing dots.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+lazy_static_cache-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+lazy_static_cache-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "lazy_static_cache" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+lazy_static_cache-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+once_cell_cache-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+once_cell_cache-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "once_cell_cache" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+once_cell_cache-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+unsafe_cache-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+unsafe_cache-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "unsafe_cache" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+unsafe_cache-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+use_unix_paths_on_wasm-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+use_unix_paths_on_wasm-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "use_unix_paths_on_wasm" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+use_unix_paths_on_wasm-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 3.1.1-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Sat Sep 09 2023 Fabio Valentini <decathorpe@gmail.com> - 3.1.1-1
|
||||
- Update to version 3.1.1; Fixes RHBZ#2238144
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Mon May 22 2023 Fabio Valentini <decathorpe@gmail.com> - 3.1.0-1
|
||||
- Update to version 3.1.0; Fixes RHBZ#2196014
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.14-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Wed Dec 14 2022 Fabio Valentini <decathorpe@gmail.com> - 3.0.14-1
|
||||
- Update to version 3.0.14; Fixes RHBZ#2134685
|
||||
|
||||
* Mon Aug 08 2022 Fabio Valentini <decathorpe@gmail.com> - 3.0.13-1
|
||||
- Update to version 3.0.13; Fixes RHBZ#2065526
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.11-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.11-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Mon Sep 27 2021 Fabio Valentini <decathorpe@gmail.com> - 3.0.11-1
|
||||
- Update to version 3.0.11; Fixes RHBZ#2005677
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.10-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Mon May 10 2021 Fabio Valentini <decathorpe@gmail.com> - 3.0.10-1
|
||||
- Update to version 3.0.10.
|
||||
- Fixes RHBZ#1952303
|
||||
|
||||
* Thu Mar 25 2021 Fabio Valentini <decathorpe@gmail.com> - 3.0.7-1
|
||||
- Update to version 3.0.7.
|
||||
- Fixes RHBZ#1937766
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Josh Stone <jistone@redhat.com> - 3.0.6-1
|
||||
- Update to 3.0.6
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sun Jun 21 09:06:41 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 3.0.0-1
|
||||
- Update to 3.0.0
|
||||
|
||||
* Thu May 28 2020 Josh Stone <jistone@redhat.com> - 2.0.2-1
|
||||
- Update to 2.0.2
|
||||
|
||||
* Wed May 27 12:12:10 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 2.0.1-1
|
||||
- Update to 2.0.1
|
||||
|
||||
* Wed May 27 07:21:23 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 2.0.0-1
|
||||
- Update to 2.0.0
|
||||
|
||||
* Tue May 26 11:51:56 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.2.1-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue