Initial import (password-hash 0.3 compat package)

epel9 imports/e9/rust-password-hash0.3-0.3.2-1.el9
Fabio Valentini 2 years ago
parent 89c8dd32f0
commit fce515bc8f
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/password-hash-0.3.2.crate

@ -1,3 +0,0 @@
# rust-password-hash0.3
The rust-password-hash0.3 package

@ -0,0 +1,20 @@
--- password-hash-0.3.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ password-hash-0.3.2/Cargo.toml 2023-04-17T21:24:53.371789+00:00
@@ -25,7 +25,7 @@
all-features = true
rustc-args = ["--cfg", "docsrs"]
[dependencies.base64ct]
-version = ">=1, <1.1.0"
+version = "1"
[dependencies.rand_core]
version = "0.6"
@@ -33,7 +33,7 @@
default-features = false
[dependencies.subtle]
-version = ">=2, <2.5"
+version = "2"
default-features = false
[features]

@ -0,0 +1,111 @@
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate password-hash
Name: rust-password-hash0.3
Version: 0.3.2
Release: %autorelease
Summary: Traits which describe password hashing algorithms
License: MIT OR Apache-2.0
URL: https://crates.io/crates/password-hash
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * relax base64ct and subtle dependencies (MSRV is irrelevant in Fedora)
Patch: password-hash-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Traits which describe the functionality of password hashing algorithms,
as well as a `no_std`-friendly implementation of the PHC string format
(a well-defined subset of the Modular Crypt Format a.k.a. MCF).}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand_core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand_core-devel %{_description}
This package contains library source intended for building other packages which
use the "rand_core" feature of the "%{crate}" crate.
%files -n %{name}+rand_core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (password-hash-0.3.2.crate) = 157cf50896c28d5a73670fe2ea9e00ceb10acd3d2c9abb13b86f0b16d3fd8c56767d5732cb997b52702432b0c25d4591d1263e24c312d0fef25a328ea0dd940d
Loading…
Cancel
Save