commit
c221cbeb2e
Binary file not shown.
@ -0,0 +1,23 @@
|
|||||||
|
--- parking_lot_core-0.8.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ parking_lot_core-0.8.6/Cargo.toml 2022-12-13T01:12:52.290025+00:00
|
||||||
|
@@ -55,20 +55,5 @@
|
||||||
|
]
|
||||||
|
nightly = []
|
||||||
|
|
||||||
|
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
|
||||||
|
-version = "0.2.8"
|
||||||
|
-
|
||||||
|
[target."cfg(unix)".dependencies.libc]
|
||||||
|
version = "0.2.95"
|
||||||
|
-
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3.9"
|
||||||
|
-features = [
|
||||||
|
- "winnt",
|
||||||
|
- "ntstatus",
|
||||||
|
- "minwindef",
|
||||||
|
- "winerror",
|
||||||
|
- "winbase",
|
||||||
|
- "errhandlingapi",
|
||||||
|
- "handleapi",
|
||||||
|
-]
|
@ -0,0 +1,151 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.0)
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 23
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate parking_lot_core
|
||||||
|
|
||||||
|
Name: rust-parking_lot_core0.8
|
||||||
|
Version: 0.8.6
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Advanced API for creating custom synchronization primitives
|
||||||
|
|
||||||
|
# Upstream license specification: Apache-2.0/MIT
|
||||||
|
License: Apache-2.0 OR MIT
|
||||||
|
URL: https://crates.io/crates/parking_lot_core
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop Windows- and Redox OS-specific dependencies
|
||||||
|
Patch: parking_lot_core-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Advanced API for creating custom synchronization primitives.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+backtrace-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+backtrace-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "backtrace" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+backtrace-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+deadlock_detection-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+deadlock_detection-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "deadlock_detection" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+deadlock_detection-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+nightly-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+nightly-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "nightly" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+nightly-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+petgraph-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+petgraph-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "petgraph" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+petgraph-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+thread-id-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+thread-id-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "thread-id" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+thread-id-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Nov 19 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.8.6-1
|
||||||
|
- Rebuilt for MSVSphere 9.2
|
||||||
|
|
||||||
|
* Tue Dec 13 2022 Fabio Valentini <decathorpe@gmail.com> 0.8.6-1
|
||||||
|
- Update to version 0.8.6
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.8.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Mar 03 2022 Fabio Valentini <decathorpe@gmail.com> 0.8.5-1
|
||||||
|
- Initial import (parking_lot_core 0.8 compat package)
|
Loading…
Reference in new issue