parent
760de595ca
commit
33b87f2fc9
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/parking_lot_core-0.8.5.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-parking_lot_core0.8
|
||||
|
||||
The rust-parking_lot_core0.8 package
|
@ -0,0 +1,13 @@
|
||||
--- parking_lot_core-0.8.5/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ parking_lot_core-0.8.5/Cargo.toml 2022-03-03T11:29:03.659007+00:00
|
||||
@@ -43,10 +43,5 @@
|
||||
[features]
|
||||
deadlock_detection = ["petgraph", "thread-id", "backtrace"]
|
||||
nightly = []
|
||||
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
|
||||
-version = "0.2.8"
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2.95"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3.9"
|
||||
-features = ["winnt", "ntstatus", "minwindef", "winerror", "winbase", "errhandlingapi", "handleapi"]
|
@ -0,0 +1,134 @@
|
||||
# Generated by rust2rpm 21
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate parking_lot_core
|
||||
|
||||
Name: rust-%{crate}0.8
|
||||
Version: 0.8.5
|
||||
Release: %autorelease
|
||||
Summary: Advanced API for creating custom synchronization primitives
|
||||
|
||||
# Upstream license specification: Apache-2.0/MIT
|
||||
License: ASL 2.0 or MIT
|
||||
URL: https://crates.io/crates/parking_lot_core
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * drop Windows- and Redox OS-specific dependencies
|
||||
Patch0: parking_lot_core-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Advanced API for creating custom synchronization primitives.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+backtrace-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+backtrace-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "backtrace" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+backtrace-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+deadlock_detection-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+deadlock_detection-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "deadlock_detection" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+deadlock_detection-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+nightly-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+nightly-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "nightly" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+nightly-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+petgraph-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+petgraph-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "petgraph" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+petgraph-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+thread-id-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+thread-id-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "thread-id" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+thread-id-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue