Merge branch 'rawhide' into epel9

epel9
Fabio Valentini 2 years ago
commit 6bb4824d54
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

2
.gitignore vendored

@ -11,3 +11,5 @@
/parking_lot_core-0.8.2.crate /parking_lot_core-0.8.2.crate
/parking_lot_core-0.8.3.crate /parking_lot_core-0.8.3.crate
/parking_lot_core-0.8.5.crate /parking_lot_core-0.8.5.crate
/parking_lot_core-0.9.1.crate
/parking_lot_core-0.9.3.crate

@ -1,13 +1,20 @@
--- parking_lot_core-0.8.5/Cargo.toml 1970-01-01T00:00:01+00:00 --- parking_lot_core-0.9.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ parking_lot_core-0.8.5/Cargo.toml 2021-11-28T07:25:42.630098+00:00 +++ parking_lot_core-0.9.3/Cargo.toml 2022-05-24T14:17:50.607577+00:00
@@ -43,10 +43,5 @@ @@ -52,17 +52,5 @@
[features] ]
deadlock_detection = ["petgraph", "thread-id", "backtrace"]
nightly = [] nightly = []
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall] -[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.2.8" -version = "0.2.8"
-
[target."cfg(unix)".dependencies.libc] [target."cfg(unix)".dependencies.libc]
version = "0.2.95" version = "0.2.95"
-[target."cfg(windows)".dependencies.winapi] -
-version = "0.3.9" -[target."cfg(windows)".dependencies.windows-sys]
-features = ["winnt", "ntstatus", "minwindef", "winerror", "winbase", "errhandlingapi", "handleapi"] -version = "0.36.0"
-features = [
- "Win32_Foundation",
- "Win32_System_LibraryLoader",
- "Win32_System_SystemServices",
- "Win32_System_WindowsProgramming",
-]

@ -1,28 +1,25 @@
# Generated by rust2rpm 19 # Generated by rust2rpm 21
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate parking_lot_core %global crate parking_lot_core
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.8.5 Version: 0.9.3
Release: %autorelease Release: %autorelease
Summary: Advanced API for creating custom synchronization primitives Summary: Advanced API for creating custom synchronization primitives
# Upstream license specification: Apache-2.0/MIT # Upstream license specification: MIT OR Apache-2.0
License: ASL 2.0 or MIT License: MIT or ASL 2.0
URL: https://crates.io/crates/parking_lot_core URL: https://crates.io/crates/parking_lot_core
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No Windows, no Redox OS # * drop Windows- and Redox OS-specific dependencies
Patch0: parking_lot_core-fix-metadata.diff Patch0: parking_lot_core-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Advanced API for creating custom synchronization primitives.} Advanced API for creating custom synchronization primitives.}
@ -36,11 +33,12 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-APACHE LICENSE-MIT %license %{crate_instdir}/LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %license %{crate_instdir}/LICENSE-MIT
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -49,10 +47,10 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+backtrace-devel %package -n %{name}+backtrace-devel
Summary: %{summary} Summary: %{summary}
@ -61,10 +59,10 @@ BuildArch: noarch
%description -n %{name}+backtrace-devel %{_description} %description -n %{name}+backtrace-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the backtrace" feature of the "%{crate}" crate. use the "backtrace" feature of the "%{crate}" crate.
%files -n %{name}+backtrace-devel %files -n %{name}+backtrace-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+deadlock_detection-devel %package -n %{name}+deadlock_detection-devel
Summary: %{summary} Summary: %{summary}
@ -73,10 +71,10 @@ BuildArch: noarch
%description -n %{name}+deadlock_detection-devel %{_description} %description -n %{name}+deadlock_detection-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the deadlock_detection" feature of the "%{crate}" crate. use the "deadlock_detection" feature of the "%{crate}" crate.
%files -n %{name}+deadlock_detection-devel %files -n %{name}+deadlock_detection-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel %package -n %{name}+nightly-devel
Summary: %{summary} Summary: %{summary}
@ -85,10 +83,10 @@ BuildArch: noarch
%description -n %{name}+nightly-devel %{_description} %description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the nightly" feature of the "%{crate}" crate. use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel %files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+petgraph-devel %package -n %{name}+petgraph-devel
Summary: %{summary} Summary: %{summary}
@ -97,10 +95,10 @@ BuildArch: noarch
%description -n %{name}+petgraph-devel %{_description} %description -n %{name}+petgraph-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the petgraph" feature of the "%{crate}" crate. use the "petgraph" feature of the "%{crate}" crate.
%files -n %{name}+petgraph-devel %files -n %{name}+petgraph-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+thread-id-devel %package -n %{name}+thread-id-devel
Summary: %{summary} Summary: %{summary}
@ -109,10 +107,10 @@ BuildArch: noarch
%description -n %{name}+thread-id-devel %{_description} %description -n %{name}+thread-id-devel %{_description}
This package contains library source intended for building other packages which This package contains library source intended for building other packages which
use "the thread-id" feature of the "%{crate}" crate. use the "thread-id" feature of the "%{crate}" crate.
%files -n %{name}+thread-id-devel %files -n %{name}+thread-id-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (parking_lot_core-0.8.5.crate) = c4315df551748d1ae77655e4d9f8c90f911498856e5358009e9e02e410bb8085f006f369188b0753a298371ebd74a5c383d848b65e31b55f3462381308c83a00 SHA512 (parking_lot_core-0.9.3.crate) = fa30db0fc73b268ab8395adb8bda35d12dc15363b247a95b7c4bb848ff9b8dbfb971a20f320b4feff3317d5b533c59b62152e4c652c1809a422c5671310b30df

Loading…
Cancel
Save