parent
08b7a13a8b
commit
3004dbf266
@ -0,0 +1 @@
|
||||
/parking_lot_core-0.3.0.crate
|
@ -0,0 +1,32 @@
|
||||
--- parking_lot_core-0.3.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ parking_lot_core-0.3.0/Cargo.toml 2018-09-03T09:27:50.290538+02:00
|
||||
@@ -19,29 +19,11 @@
|
||||
categories = ["concurrency"]
|
||||
license = "Apache-2.0/MIT"
|
||||
repository = "https://github.com/Amanieu/parking_lot"
|
||||
-[dependencies.backtrace]
|
||||
-version = "0.3.2"
|
||||
-optional = true
|
||||
-
|
||||
-[dependencies.petgraph]
|
||||
-version = "0.4.5"
|
||||
-optional = true
|
||||
-
|
||||
[dependencies.rand]
|
||||
version = "0.5"
|
||||
|
||||
[dependencies.smallvec]
|
||||
version = "0.6"
|
||||
|
||||
-[dependencies.thread-id]
|
||||
-version = "3.2.0"
|
||||
-optional = true
|
||||
-
|
||||
-[features]
|
||||
-deadlock_detection = ["petgraph", "thread-id", "backtrace"]
|
||||
-nightly = []
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2.27"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = ["winnt", "ntstatus", "minwindef", "winerror", "winbase", "errhandlingapi", "handleapi"]
|
@ -0,0 +1,64 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate parking_lot_core
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.3.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Advanced API for creating custom synchronization primitives
|
||||
|
||||
# Upstream license specification: Apache-2.0/MIT
|
||||
# https://github.com/Amanieu/parking_lot/issues/92
|
||||
License: ASL 2.0 or MIT
|
||||
URL: https://crates.io/crates/parking_lot_core
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No Windows
|
||||
# * No nightly
|
||||
# * No optional features
|
||||
Patch0: parking_lot_core-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(libc) >= 0.2.27 with crate(libc) < 0.3.0)
|
||||
BuildRequires: (crate(rand) >= 0.5.0 with crate(rand) < 0.6.0)
|
||||
BuildRequires: (crate(smallvec) >= 0.6.0 with crate(smallvec) < 0.7.0)
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
An advanced API for creating custom synchronization primitives.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Mon Sep 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue