Update to 0.17.0

Signed-off-by: Michel Alexandre Salim <salimma@fedoraproject.org>
epel9
Michel Alexandre Salim 2 years ago
parent 4df3a89fb3
commit 5a19bfafa0
No known key found for this signature in database
GPG Key ID: 8B229D2F7CCC04F2

1
.gitignore vendored

@ -1 +1,2 @@
/pancurses-0.16.1.crate /pancurses-0.16.1.crate
/pancurses-0.17.0.crate

@ -0,0 +1,11 @@
--- pancurses-0.17.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pancurses-0.17.0/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -39,8 +39,3 @@
win32a = ["pdcurses-sys/win32a"]
[target."cfg(unix)".dependencies.ncurses]
version = "5.101.0"
-[target."cfg(windows)".dependencies.pdcurses-sys]
-version = "0.7"
-
-[target."cfg(windows)".dependencies.winreg]
-version = "0.5"

@ -1,15 +1,10 @@
--- pancurses-0.16.1/Cargo.toml 1970-01-01T00:00:00+00:00 --- pancurses-0.17.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ pancurses-0.16.1/Cargo.toml 2021-05-19T16:03:15.128169+00:00 +++ pancurses-0.17.0/Cargo.toml 2023-01-20T19:35:25.585039+00:00
@@ -36,12 +36,5 @@ @@ -35,7 +35,5 @@
disable_resize = [] disable_resize = []
show_menu = [] show_menu = []
wide = ["ncurses/wide"] wide = ["ncurses/wide"]
-win32 = ["pdcurses-sys/win32"] -win32 = ["pdcurses-sys/win32"]
-win32a = ["pdcurses-sys/win32a"] -win32a = ["pdcurses-sys/win32a"]
[target."cfg(unix)".dependencies.ncurses] [target."cfg(unix)".dependencies.ncurses]
version = "5.91.0" version = "5.101.0"
-[target."cfg(windows)".dependencies.pdcurses-sys]
-version = "0.7"
-
-[target."cfg(windows)".dependencies.winreg]
-version = "0.5"

@ -1,30 +1,27 @@
# Generated by rust2rpm 16 # Generated by rust2rpm 23
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate pancurses %global crate pancurses
Name: rust-%{crate} Name: rust-pancurses
Version: 0.16.1 Version: 0.17.0
Release: %autorelease Release: %autorelease
Summary: Curses libary for Rust that supports both Unix and Windows Summary: Curses library for Rust that supports both Unix and Windows
# Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/pancurses URL: https://crates.io/crates/pancurses
Source: %{crates_source} Source: %{crates_source}
# Drop Windows features and dependencies from metadata # Automatically generated patch to strip foreign dependencies
Patch0: pancurses-fix-metadata.diff Patch: pancurses-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop Windows features
Patch: pancurses-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: rust-packaging >= 21
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
Curses libary for Rust that supports both Unix and Windows platforms by Curses library for Rust that supports both Unix and Windows platforms by
abstracting away the backend that it uses (ncurses-rs and pdcurses-sys abstracting away the backend that it uses (ncurses-rs and pdcurses-sys
respectively).} respectively).}
@ -36,13 +33,13 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE.md %license %{crate_instdir}/LICENSE.md
%doc README.md %doc %{crate_instdir}/README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -50,11 +47,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+disable_resize-devel %package -n %{name}+disable_resize-devel
Summary: %{summary} Summary: %{summary}
@ -62,11 +59,11 @@ BuildArch: noarch
%description -n %{name}+disable_resize-devel %{_description} %description -n %{name}+disable_resize-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "disable_resize" feature of "%{crate}" crate. use the "disable_resize" feature of the "%{crate}" crate.
%files -n %{name}+disable_resize-devel %files -n %{name}+disable_resize-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+show_menu-devel %package -n %{name}+show_menu-devel
Summary: %{summary} Summary: %{summary}
@ -74,11 +71,11 @@ BuildArch: noarch
%description -n %{name}+show_menu-devel %{_description} %description -n %{name}+show_menu-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "show_menu" feature of "%{crate}" crate. use the "show_menu" feature of the "%{crate}" crate.
%files -n %{name}+show_menu-devel %files -n %{name}+show_menu-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+wide-devel %package -n %{name}+wide-devel
Summary: %{summary} Summary: %{summary}
@ -86,11 +83,11 @@ BuildArch: noarch
%description -n %{name}+wide-devel %{_description} %description -n %{name}+wide-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "wide" feature of "%{crate}" crate. use the "wide" feature of the "%{crate}" crate.
%files -n %{name}+wide-devel %files -n %{name}+wide-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (pancurses-0.16.1.crate) = 2d9fdd6077eb64575a2af28201bf6dac45da628625109255675fa4324de293e591656bc2a06c9d8ef0d18cfd72d5163c10a028d300a9fb3ac32387aad7381973 SHA512 (pancurses-0.17.0.crate) = 048740f35324f6c702bb98a608c6497b77415bdeeb4a83978d85dd66bd0b352a952adbd50546021b039fb30be3a47dfeb3022f92fc1a96126a5069d5ebb14b1a

Loading…
Cancel
Save