import #1962269
parent
1ecae123c5
commit
16750e303f
@ -0,0 +1 @@
|
|||||||
|
/pancurses-0.16.1.crate
|
@ -0,0 +1,15 @@
|
|||||||
|
--- pancurses-0.16.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ pancurses-0.16.1/Cargo.toml 2021-05-19T16:03:15.128169+00:00
|
||||||
|
@@ -36,12 +36,5 @@
|
||||||
|
disable_resize = []
|
||||||
|
show_menu = []
|
||||||
|
wide = ["ncurses/wide"]
|
||||||
|
-win32 = ["pdcurses-sys/win32"]
|
||||||
|
-win32a = ["pdcurses-sys/win32a"]
|
||||||
|
[target."cfg(unix)".dependencies.ncurses]
|
||||||
|
version = "5.91.0"
|
||||||
|
-[target."cfg(windows)".dependencies.pdcurses-sys]
|
||||||
|
-version = "0.7"
|
||||||
|
-
|
||||||
|
-[target."cfg(windows)".dependencies.winreg]
|
||||||
|
-version = "0.5"
|
@ -0,0 +1,115 @@
|
|||||||
|
# Generated by rust2rpm 16
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate pancurses
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.16.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Curses libary for Rust that supports both Unix and Windows
|
||||||
|
|
||||||
|
# Upstream license specification: MIT
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/pancurses
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Drop Windows features and dependencies from metadata
|
||||||
|
Patch0: pancurses-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Curses libary for Rust that supports both Unix and Windows platforms by
|
||||||
|
abstracting away the backend that it uses (ncurses-rs and pdcurses-sys
|
||||||
|
respectively).}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE.md
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+disable_resize-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+disable_resize-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "disable_resize" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+disable_resize-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+show_menu-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+show_menu-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "show_menu" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+show_menu-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+wide-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+wide-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "wide" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+wide-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed May 19 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.16.1-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue