commit
05c289554a
Binary file not shown.
@ -0,0 +1,11 @@
|
|||||||
|
--- pancurses-0.17.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ pancurses-0.17.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
@@ -39,8 +39,3 @@
|
||||||
|
win32a = ["pdcurses-sys/win32a"]
|
||||||
|
[target."cfg(unix)".dependencies.ncurses]
|
||||||
|
version = "5.101.0"
|
||||||
|
-[target."cfg(windows)".dependencies.pdcurses-sys]
|
||||||
|
-version = "0.7"
|
||||||
|
-
|
||||||
|
-[target."cfg(windows)".dependencies.winreg]
|
||||||
|
-version = "0.5"
|
@ -0,0 +1,10 @@
|
|||||||
|
--- pancurses-0.17.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ pancurses-0.17.0/Cargo.toml 2023-01-20T19:35:25.585039+00:00
|
||||||
|
@@ -35,7 +35,5 @@
|
||||||
|
disable_resize = []
|
||||||
|
show_menu = []
|
||||||
|
wide = ["ncurses/wide"]
|
||||||
|
-win32 = ["pdcurses-sys/win32"]
|
||||||
|
-win32a = ["pdcurses-sys/win32a"]
|
||||||
|
[target."cfg(unix)".dependencies.ncurses]
|
||||||
|
version = "5.101.0"
|
@ -0,0 +1,141 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.1)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 2;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 23
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate pancurses
|
||||||
|
|
||||||
|
Name: rust-pancurses
|
||||||
|
Version: 0.17.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Curses library for Rust that supports both Unix and Windows
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/pancurses
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip foreign dependencies
|
||||||
|
Patch: pancurses-fix-metadata-auto.diff
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop Windows features
|
||||||
|
Patch: pancurses-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Curses library for Rust that supports both Unix and Windows platforms by
|
||||||
|
abstracting away the backend that it uses (ncurses-rs and pdcurses-sys
|
||||||
|
respectively).}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+disable_resize-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+disable_resize-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "disable_resize" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+disable_resize-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+show_menu-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+show_menu-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "show_menu" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+show_menu-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+wide-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+wide-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "wide" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+wide-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.17.0-2
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.17.0-1
|
||||||
|
- Update to 0.17.0
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed May 19 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.16.1-1
|
||||||
|
- Initial package
|
||||||
|
|
Loading…
Reference in new issue