commit
e8bb8a6faa
Binary file not shown.
@ -0,0 +1,47 @@
|
||||
--- palette-0.7.3/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ palette-0.7.3/Cargo.toml 2023-11-29T12:12:08.032154+00:00
|
||||
@@ -57,21 +57,6 @@
|
||||
name = "issue_283"
|
||||
path = "regression_tests/issue_283.rs"
|
||||
|
||||
-[[bench]]
|
||||
-name = "cie_conversion"
|
||||
-path = "benches/cie.rs"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "rgb_conversion"
|
||||
-path = "benches/rgb.rs"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "matrix"
|
||||
-path = "benches/matrix.rs"
|
||||
-harness = false
|
||||
-
|
||||
[dependencies.approx]
|
||||
version = "0.5"
|
||||
optional = true
|
||||
@@ -117,10 +102,6 @@
|
||||
version = "3.2.23"
|
||||
default-features = false
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.4.0"
|
||||
-default-features = false
|
||||
-
|
||||
[dev-dependencies.csv]
|
||||
version = "1"
|
||||
|
||||
@@ -134,11 +115,6 @@
|
||||
|
||||
[dev-dependencies.lazy_static]
|
||||
version = "1"
|
||||
-
|
||||
-[dev-dependencies.rand_mt]
|
||||
-version = "4"
|
||||
-features = ["rand-traits"]
|
||||
-default-features = false
|
||||
|
||||
[dev-dependencies.ron]
|
||||
version = "0.8.0"
|
@ -0,0 +1,292 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
# * missing dev-dependencies: enterpolation ^0.2, scad ^1.2.2
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate palette
|
||||
|
||||
Name: rust-palette
|
||||
Version: 0.7.3
|
||||
Release: %autorelease
|
||||
Summary: Convert and manage colors with a focus on correctness, flexibility and ease of use
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/palette
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused rand_mt dev-dependency
|
||||
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||
Patch: palette-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Convert and manage colors with a focus on correctness, flexibility and
|
||||
ease of use.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+approx-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+approx-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "approx" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+approx-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+bytemuck-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+bytemuck-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "bytemuck" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+bytemuck-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+find-crate-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+find-crate-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "find-crate" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+find-crate-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+libm-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+libm-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "libm" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+libm-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+named-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+named-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "named" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+named-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+named_from_str-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+named_from_str-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "named_from_str" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+named_from_str-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+phf-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+phf-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "phf" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+phf-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rand" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+random-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+random-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "random" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+random-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serializing-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serializing-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serializing" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serializing-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+wide-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+wide-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "wide" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+wide-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.7.3-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Wed Nov 29 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.3-1
|
||||
- Update to version 0.7.3; Fixes RHBZ#2107821
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Sun Mar 12 2023 Fabio Valentini <decathorpe@gmail.com> - 0.6.0-11
|
||||
- Regenerate with rust2rpm v24
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Fri Nov 04 2022 Fabio Valentini <decathorpe@gmail.com> - 0.6.0-9
|
||||
- Drop unused, benchmark-only criterion dev-dependency
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Dec 10 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.6.0-6
|
||||
- Add patch
|
||||
|
||||
* Fri Dec 10 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.6.0-5
|
||||
- Fix dependency
|
||||
|
||||
* Fri Dec 10 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.6.0-4
|
||||
- Update spec for rust2rpm 20
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Mon Jul 19 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.6.0-1
|
||||
- Update to version 0.6.0.
|
||||
- Fixes RHBZ#1981483
|
||||
|
||||
* Mon Jun 28 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.0-4
|
||||
- Bump approx from 0.3 to 0.5.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Dec 28 13:31:41 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.5.0-2
|
||||
- Rebuild
|
||||
|
||||
* Sat Sep 19 2020 Fabio Valentini <decathorpe@gmail.com> - 0.5.0-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue