Drop unused, benchmark-only criterion dev-dependency

epel9
Fabio Valentini 2 years ago
parent a5ba536dad
commit 895e7fa9e1
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,5 +1,5 @@
--- palette-0.6.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ palette-0.6.0/Cargo.toml 2021-12-10T07:39:46.344758+00:00
+++ palette-0.6.0/Cargo.toml 2022-11-04T20:04:01.009987+00:00
@@ -58,7 +58,7 @@
version = "0.6.0"
@ -9,15 +9,26 @@
features = ["macros"]
optional = true
default-features = false
@@ -91,11 +91,6 @@
[dev-dependencies.lazy_static]
@@ -76,10 +76,6 @@
version = "2"
default-features = false
-[dev-dependencies.criterion]
-version = "0.3"
-default-features = false
-
[dev-dependencies.csv]
version = "1"
@@ -90,11 +86,6 @@
[dev-dependencies.lazy_static]
version = "1"
-
-[dev-dependencies.rand_mt]
-version = "4"
-features = ["rand-traits"]
-default-features = false
-
[dev-dependencies.serde]
version = "1"

@ -1,26 +1,24 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}
%global crate palette
Name: rust-%{crate}
Name: rust-palette
Version: 0.6.0
Release: %autorelease
Summary: Convert and manage colors with a focus on correctness, flexibility and ease of use
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/palette
Source: %{crates_source}
# Initial patched metadata
# Downgrade phf to version 0.8
# Remove rand_mt dev-dependencies
Patch0: palette-fix-metadata.diff
# Manually created patch for downstream crate metadata changes
# * temporarily downgrade phf from 0.9 to 0.8
# * drop unused rand_mt dev-dependency
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
Patch: palette-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Convert and manage colors with a focus on correctness, flexibility and ease of
@ -34,13 +32,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -48,11 +47,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytemuck-devel
Summary: %{summary}
@ -60,11 +59,11 @@ BuildArch: noarch
%description -n %{name}+bytemuck-devel %{_description}
This package contains library source intended for building other packages
which use "bytemuck" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "bytemuck" feature of the "%{crate}" crate.
%files -n %{name}+bytemuck-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libm-devel
Summary: %{summary}
@ -72,11 +71,11 @@ BuildArch: noarch
%description -n %{name}+libm-devel %{_description}
This package contains library source intended for building other packages
which use "libm" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "libm" feature of the "%{crate}" crate.
%files -n %{name}+libm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+named-devel
Summary: %{summary}
@ -84,11 +83,11 @@ BuildArch: noarch
%description -n %{name}+named-devel %{_description}
This package contains library source intended for building other packages
which use "named" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "named" feature of the "%{crate}" crate.
%files -n %{name}+named-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+named_from_str-devel
Summary: %{summary}
@ -96,11 +95,11 @@ BuildArch: noarch
%description -n %{name}+named_from_str-devel %{_description}
This package contains library source intended for building other packages
which use "named_from_str" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "named_from_str" feature of the "%{crate}" crate.
%files -n %{name}+named_from_str-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+named_gradients-devel
Summary: %{summary}
@ -108,11 +107,11 @@ BuildArch: noarch
%description -n %{name}+named_gradients-devel %{_description}
This package contains library source intended for building other packages
which use "named_gradients" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "named_gradients" feature of the "%{crate}" crate.
%files -n %{name}+named_gradients-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+phf-devel
Summary: %{summary}
@ -120,11 +119,11 @@ BuildArch: noarch
%description -n %{name}+phf-devel %{_description}
This package contains library source intended for building other packages
which use "phf" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "phf" feature of the "%{crate}" crate.
%files -n %{name}+phf-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
@ -132,11 +131,11 @@ BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages
which use "rand" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+random-devel
Summary: %{summary}
@ -144,11 +143,11 @@ BuildArch: noarch
%description -n %{name}+random-devel %{_description}
This package contains library source intended for building other packages
which use "random" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "random" feature of the "%{crate}" crate.
%files -n %{name}+random-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
@ -156,11 +155,11 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serializing-devel
Summary: %{summary}
@ -168,11 +167,11 @@ BuildArch: noarch
%description -n %{name}+serializing-devel %{_description}
This package contains library source intended for building other packages
which use "serializing" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "serializing" feature of the "%{crate}" crate.
%files -n %{name}+serializing-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -180,11 +179,11 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

Loading…
Cancel
Save