Update to version 0.7.3; Fixes RHBZ#2107821

epel9 imports/e9/rust-palette-0.7.3-1.el9
Fabio Valentini 1 year ago
parent 70a11f92f8
commit 7bd1efdd4c
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/palette-0.5.0.crate
/palette-0.6.0.crate
/palette-0.7.3.crate

@ -1,8 +1,8 @@
--- palette-0.6.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ palette-0.6.0/Cargo.toml 2023-03-12T21:48:56.717273+00:00
@@ -28,20 +28,6 @@
[lib]
bench = false
--- palette-0.7.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ palette-0.7.3/Cargo.toml 2023-11-29T12:12:08.032154+00:00
@@ -57,21 +57,6 @@
name = "issue_283"
path = "regression_tests/issue_283.rs"
-[[bench]]
-name = "cie_conversion"
@ -18,30 +18,22 @@
-name = "matrix"
-path = "benches/matrix.rs"
-harness = false
-
[dependencies.approx]
version = "0.5"
default-features = false
@@ -58,7 +44,7 @@
version = "0.6.0"
[dependencies.phf]
-version = "0.9"
+version = "0.8"
features = ["macros"]
optional = true
default-features = false
@@ -76,10 +62,6 @@
version = "2"
@@ -117,10 +102,6 @@
version = "3.2.23"
default-features = false
-[dev-dependencies.criterion]
-version = "0.3"
-version = "0.4.0"
-default-features = false
-
[dev-dependencies.csv]
version = "1"
@@ -90,11 +72,6 @@
@@ -134,11 +115,6 @@
[dev-dependencies.lazy_static]
version = "1"
@ -51,5 +43,5 @@
-features = ["rand-traits"]
-default-features = false
[dev-dependencies.serde]
version = "1"
[dev-dependencies.ron]
version = "0.8.0"

@ -1,11 +1,12 @@
# Generated by rust2rpm 24
%bcond_without check
# Generated by rust2rpm 25
# * missing dev-dependencies: enterpolation ^0.2, scad ^1.2.2
%bcond_with check
%global debug_package %{nil}
%global crate palette
Name: rust-palette
Version: 0.6.0
Version: 0.7.3
Release: %autorelease
Summary: Convert and manage colors with a focus on correctness, flexibility and ease of use
@ -13,12 +14,11 @@ License: MIT OR Apache-2.0
URL: https://crates.io/crates/palette
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * temporarily downgrade phf from 0.9 to 0.8
# * drop unused rand_mt dev-dependency
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
Patch: palette-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Convert and manage colors with a focus on correctness, flexibility and
@ -53,6 +53,18 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+approx-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+approx-devel %{_description}
This package contains library source intended for building other packages which
use the "approx" feature of the "%{crate}" crate.
%files -n %{name}+approx-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytemuck-devel
Summary: %{summary}
BuildArch: noarch
@ -65,6 +77,18 @@ use the "bytemuck" feature of the "%{crate}" crate.
%files -n %{name}+bytemuck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+find-crate-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+find-crate-devel %{_description}
This package contains library source intended for building other packages which
use the "find-crate" feature of the "%{crate}" crate.
%files -n %{name}+find-crate-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libm-devel
Summary: %{summary}
BuildArch: noarch
@ -101,18 +125,6 @@ use the "named_from_str" feature of the "%{crate}" crate.
%files -n %{name}+named_from_str-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+named_gradients-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+named_gradients-devel %{_description}
This package contains library source intended for building other packages which
use the "named_gradients" feature of the "%{crate}" crate.
%files -n %{name}+named_gradients-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+phf-devel
Summary: %{summary}
BuildArch: noarch
@ -185,8 +197,20 @@ use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+wide-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+wide-devel %{_description}
This package contains library source intended for building other packages which
use the "wide" feature of the "%{crate}" crate.
%files -n %{name}+wide-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires

@ -1 +1 @@
SHA512 (palette-0.6.0.crate) = 541ebb5112651b1d688c26a7b122ccb76fae89a6a6b00e98a6c2b714587ec166f3f97ebe2cb21a5321b406718803d47b6fa1f4df30b55012a8cfb8cd4d7a280e
SHA512 (palette-0.7.3.crate) = 7fcfb59b4b3adf6d6041fc72767c23c235351571864a11101a294892135b056acdf52b353425d8701f6ea26605ad3e678855498eb38a4d980af4721a622691a0

Loading…
Cancel
Save