initial import (#1880720)
parent
317ef7e9d6
commit
0d158b4fff
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/palette-0.5.0.crate
|
@ -0,0 +1,11 @@
|
||||
--- palette-0.5.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ palette-0.5.0/Cargo.toml 2020-09-19T09:49:16.828376+00:00
|
||||
@@ -48,7 +48,7 @@
|
||||
version = "1"
|
||||
|
||||
[dev-dependencies.image]
|
||||
-version = "0.22"
|
||||
+version = "0.23"
|
||||
|
||||
[dev-dependencies.lazy_static]
|
||||
version = "1"
|
@ -0,0 +1,185 @@
|
||||
# Generated by rust2rpm 13
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate palette
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.5.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Makes linear color calculations and conversion easy and accessible for anyone
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/palette
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
Patch0: palette-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Makes linear color calculations and conversion easy and accessible for anyone.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-APACHE LICENSE-MIT
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+libm-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+libm-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "libm" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+libm-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+named-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+named-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "named" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+named-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+named_from_str-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+named_from_str-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "named_from_str" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+named_from_str-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+phf-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+phf-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "phf" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+phf-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+phf_codegen-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+phf_codegen-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "phf_codegen" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+phf_codegen-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "serde" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serializing-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serializing-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "serializing" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serializing-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "std" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+strict-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+strict-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "strict" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+strict-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Sep 19 2020 Fabio Valentini <decathorpe@gmail.com> - 0.5.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue