parent
768a1febf8
commit
bbb959b7bb
@ -0,0 +1,4 @@
|
|||||||
|
/results_*/
|
||||||
|
/*.src.rpm
|
||||||
|
|
||||||
|
/os_pipe-0.9.2.crate
|
@ -0,0 +1,12 @@
|
|||||||
|
--- os_pipe-0.9.2/Cargo.toml 2020-05-28T02:10:52+00:00
|
||||||
|
+++ os_pipe-0.9.2/Cargo.toml 2022-02-03T14:14:50.328758+00:00
|
||||||
|
@@ -20,8 +20,6 @@
|
||||||
|
readme = "README.md"
|
||||||
|
license = "MIT"
|
||||||
|
repository = "https://github.com/oconnor663/os_pipe.rs"
|
||||||
|
+autobins = false
|
||||||
|
[target."cfg(not(windows))".dependencies.libc]
|
||||||
|
version = "0.2.62"
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3.5"
|
||||||
|
-features = ["handleapi", "namedpipeapi", "processthreadsapi", "winnt"]
|
@ -0,0 +1,76 @@
|
|||||||
|
# Generated by rust2rpm 20
|
||||||
|
# * tests require building the example binaries
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate os_pipe
|
||||||
|
|
||||||
|
Name: rust-%{crate}0.9
|
||||||
|
Version: 0.9.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Cross-platform library for opening OS pipes
|
||||||
|
|
||||||
|
# Upstream license specification: MIT
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/os_pipe
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * drop windows-specific dependencies
|
||||||
|
# * drop unwanted example binaries
|
||||||
|
Patch0: os_pipe-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Cross-platform library for opening OS pipes.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue