parent
0be2683cca
commit
04b35565e1
@ -0,0 +1 @@
|
|||||||
|
/os_pipe-0.8.1.crate
|
@ -0,0 +1,11 @@
|
|||||||
|
--- os_pipe-0.8.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ os_pipe-0.8.1/Cargo.toml 2019-07-07T14:18:20.977524+00:00
|
||||||
|
@@ -19,7 +19,4 @@
|
||||||
|
license = "MIT"
|
||||||
|
repository = "https://github.com/oconnor663/os_pipe.rs"
|
||||||
|
[target."cfg(not(windows))".dependencies.nix]
|
||||||
|
-version = "0.13.0"
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3.5"
|
||||||
|
-features = ["handleapi", "namedpipeapi", "processenv", "winbase"]
|
||||||
|
+version = "0.14.0"
|
@ -0,0 +1,82 @@
|
|||||||
|
# Generated by rust2rpm 10
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
# https://github.com/oconnor663/os_pipe.rs/issues/18
|
||||||
|
%global __cargo_is_bin() false
|
||||||
|
|
||||||
|
%global crate os_pipe
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.8.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Cross-platform library for opening OS pipes
|
||||||
|
|
||||||
|
# Upstream license specification: MIT
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/os_pipe
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No windows
|
||||||
|
# * Update nix to 0.14, https://github.com/oconnor663/os_pipe.rs/pull/17<Paste>
|
||||||
|
Patch0: os_pipe-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Cross-platform library for opening OS pipes.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Jul 07 16:18:21 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-1
|
||||||
|
- Initial package
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (os_pipe-0.8.1.crate) = 731f8708e3b14771b79c3ba528f01fe484d969819f5b0900d9fa91ec2bd836b3cdc8d302513a0959d63978e6ff7705cd31d00061e9909b40d5e8864cbe5aa489
|
@ -0,0 +1 @@
|
|||||||
|
1
|
@ -0,0 +1,5 @@
|
|||||||
|
---
|
||||||
|
standard-inventory-qcow2:
|
||||||
|
qemu:
|
||||||
|
# `cargo test` usually eats more than 1G.
|
||||||
|
m: 4G
|
@ -0,0 +1,13 @@
|
|||||||
|
---
|
||||||
|
- hosts: localhost
|
||||||
|
roles:
|
||||||
|
- role: standard-test-basic
|
||||||
|
tags:
|
||||||
|
- classic
|
||||||
|
repositories:
|
||||||
|
- repo: "https://src.fedoraproject.org/tests/rust.git"
|
||||||
|
dest: rust
|
||||||
|
tests:
|
||||||
|
- rust/cargo-test
|
||||||
|
environment:
|
||||||
|
pkg: rust-os_pipe
|
Loading…
Reference in new issue