Initial import (#2210897)
parent
f636958cec
commit
7ec358d711
@ -0,0 +1 @@
|
||||
/orion-0.17.4.crate
|
@ -0,0 +1,12 @@
|
||||
--- orion-0.17.4/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ orion-0.17.4/Cargo.toml 2023-05-30T00:56:43.112584+00:00
|
||||
@@ -77,9 +77,6 @@
|
||||
version = "1.1.0"
|
||||
default-features = false
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.4.0"
|
||||
-
|
||||
[dev-dependencies.hex]
|
||||
version = "0.4.0"
|
||||
|
@ -0,0 +1,134 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate orion
|
||||
|
||||
Name: rust-orion
|
||||
Version: 0.17.4
|
||||
Release: %autorelease
|
||||
Summary: Usable, easy and safe pure-Rust crypto
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/orion
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||
Patch: orion-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Usable, easy and safe pure-Rust crypto.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/CONTRIBUTING.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%doc %{crate_instdir}/SECURITY.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "alloc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+alloc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+ct-codecs-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+ct-codecs-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "ct-codecs" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+ct-codecs-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+getrandom-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+getrandom-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "getrandom" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+getrandom-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+safe_api-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+safe_api-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "safe_api" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+safe_api-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue