parent
f6cc434b17
commit
27fc4188d6
@ -0,0 +1 @@
|
|||||||
|
/opener-0.5.2.crate
|
@ -0,0 +1,18 @@
|
|||||||
|
--- opener-0.5.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ opener-0.5.2/Cargo.toml 2023-11-09T14:44:21.179692+00:00
|
||||||
|
@@ -32,10 +32,6 @@
|
||||||
|
[target."cfg(target_os = \"linux\")".dependencies.bstr]
|
||||||
|
version = "1"
|
||||||
|
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3"
|
||||||
|
-features = ["shellapi"]
|
||||||
|
-
|
||||||
|
[badges.appveyor]
|
||||||
|
branch = "master"
|
||||||
|
repository = "Seeker14491/opener"
|
||||||
|
@@ -47,3 +43,4 @@
|
||||||
|
[badges.travis-ci]
|
||||||
|
branch = "master"
|
||||||
|
repository = "Seeker14491/opener"
|
||||||
|
+
|
@ -0,0 +1,72 @@
|
|||||||
|
# Generated by rust2rpm 25
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate opener
|
||||||
|
|
||||||
|
Name: rust-opener0.5
|
||||||
|
Version: 0.5.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Open a file or link using the system default program
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/opener
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip dependencies and normalize metadata
|
||||||
|
Patch: opener-fix-metadata-auto.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Open a file or link using the system default program.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%license %{crate_instdir}/LICENSE-THIRD-PARTY
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue