Initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 52443602e6
commit e8c926fed9
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -0,0 +1 @@
/open-1.2.2.crate

@ -0,0 +1,3 @@
[DEFAULT]
lib.requires =
/usr/bin/xdg-open

@ -0,0 +1,15 @@
--- open-1.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ open-1.2.2/Cargo.toml 2019-03-14T00:09:01.196574+01:00
@@ -19,11 +19,9 @@
keywords = ["open", "xdg-open", "start", "launch"]
license = "MIT"
repository = "https://github.com/Byron/open-rs"
+exclude = ["/etc/*", "/.clog.toml", "/.travis.yml"]
[[bin]]
name = "open"
test = false
doc = false
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["shellapi"]

@ -0,0 +1,76 @@
# Generated by rust2rpm
%bcond_with check
%global debug_package %{nil}
# Binary is useless
%global __cargo_is_bin() false
%global crate open
Name: rust-%{crate}
Version: 1.2.2
Release: 1%{?dist}
Summary: Open a path or URL using the program configured on the system
License: MIT
URL: https://crates.io/crates/open
Source: %{crates_source}
# Initial patched metadata
# * No windows
# * Exclude unneeded files, https://github.com/Byron/open-rs/pull/18
Patch0: open-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
%global _description \
Open a path or URL using the program configured on the system.
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
Requires: /usr/bin/xdg-open
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE.md
%doc README.md changelog.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Thu Mar 14 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.2.2-1
- Initial package

@ -0,0 +1 @@
SHA512 (open-1.2.2.crate) = 1485d026f9db2a65d84f481e5da8777aeada7666554b95030e1f203898e4ee94b516a8b95907d6c232fc3e6f3f0263eb85fd5aff0fdd02612c74c1df6a1ea0f9

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-open
Loading…
Cancel
Save