update to version 69.5.1

epel9
Fabio Valentini 4 years ago
parent a57eccc4d2
commit a6f1f5d723
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -4,3 +4,4 @@
/onig_sys-69.1.0.crate
/onig_sys-69.2.0.crate
/onig_sys-69.5.0.crate
/onig_sys-69.5.1.crate

@ -10,7 +10,7 @@ Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
2 files changed, 2 insertions(+), 16 deletions(-)
diff --git a/build.rs b/build.rs
index c7cb1fa..2155fe2 100644
index cf1b6f3..d704fce 100644
--- a/build.rs
+++ b/build.rs
@@ -1,4 +1,3 @@
@ -18,15 +18,18 @@ index c7cb1fa..2155fe2 100644
extern crate bindgen;
extern crate cc;
extern crate pkg_config;
@@ -187,7 +186,6 @@ fn compile() {
@@ -196,10 +195,6 @@ fn compile() {
cc.compile("onig");
}
fn bindgen_headers(_path: &str) {
- #[cfg(feature = "generate")]
{
let bindings = bindgen::Builder::default()
.header(_path)
@@ -205,13 +203,13 @@ fn bindgen_headers(_path: &str) {
-#[cfg(not(feature = "generate"))]
-fn bindgen_headers(_path: &str) {}
-
-#[cfg(feature = "generate")]
fn bindgen_headers(path: &str) {
let arch = env::var("CARGO_CFG_TARGET_ARCH");
let mut bindgen = bindgen::Builder::default()
@@ -219,17 +214,13 @@ fn bindgen_headers(path: &str) {
pub fn main() {
let link_type = link_type_override();
@ -37,7 +40,11 @@ index c7cb1fa..2155fe2 100644
let mut conf = Config::new();
// dynamically-generated headers can work with an older version
// pre-generated headers are for the latest
- conf.atleast_version(if cfg!(feature = "generate") {"6.8.0"} else {"6.9.3"});
- conf.atleast_version(if cfg!(feature = "generate") {
- "6.8.0"
- } else {
- "6.9.3"
- });
+ conf.atleast_version("6.8.0");
if link_type == Some(LinkType::Static) {
conf.statik(true);
@ -66,6 +73,3 @@ index 4d855ad..c9b6d20 100644
// backfill types from the old hand-written bindings:
pub type OnigSyntaxBehavior = ::std::os::raw::c_uint;
--
2.26.2

@ -1,10 +1,10 @@
--- onig_sys-69.5.0/Cargo.toml 2020-05-16T10:47:58+00:00
+++ onig_sys-69.5.0/Cargo.toml 2020-05-30T00:51:16.528200+00:00
--- onig_sys-69.5.1/Cargo.toml 2020-09-09T17:48:07+00:00
+++ onig_sys-69.5.1/Cargo.toml 2020-09-23T15:17:18.342497+00:00
@@ -23,9 +23,8 @@
license = "MIT"
repository = "http://github.com/iwillspeak/rust-onig"
[build-dependencies.bindgen]
-version = "0.53"
-version = "0.55"
+version = "0.54"
features = ["runtime"]
-optional = true

@ -5,8 +5,8 @@
%global crate onig_sys
Name: rust-%{crate}
Version: 69.5.0
Release: 4%{?dist}
Version: 69.5.1
Release: 1%{?dist}
Summary: Raw rust bindings to the oniguruma library
# Upstream license specification: MIT
@ -14,7 +14,7 @@ License: MIT
URL: https://crates.io/crates/onig_sys
Source: %{crates_source}
# Initial patched metadata
# * Bump to bindgen 0.54, https://github.com/rust-onig/rust-onig/pull/143
# * Downgrade bindgen from 0.55 to 0.54 until it can be updated in fedora
# * Make bindgen as non-optional dep (for next patch)
Patch0: onig_sys-fix-metadata.diff
# Always use system onig
@ -119,6 +119,9 @@ echo 'pkgconfig(oniguruma) >= 6.8.0'
%endif
%changelog
* Wed Sep 23 2020 Fabio Valentini <decathorpe@gmail.com> - 69.5.1-1
- Update to version 69.5.1.
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 69.5.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

@ -1 +1 @@
SHA512 (onig_sys-69.5.0.crate) = 644019ca67a89790bab5cb173f5499bf3b0af5a4c39e027e79a63e5752f471c6bff86f679e1c86502b6c3cf795c23cd461a87c36b2eb687dfe21e9d232bcb7ac
SHA512 (onig_sys-69.5.1.crate) = d85005612206a383af1a00ea508d076d27e31109659a9741e55deaa8423aa649a90af6cdaead67143943f3f9e1db212d5a88597b600a116067f7a5d855a9a379

Loading…
Cancel
Save