parent
6baf387cee
commit
5a836c1fd3
@ -0,0 +1,71 @@
|
||||
From 5aabe30b197ae7d7c158065215855d8bd3274d75 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Raits <i.gnatenko.brain@gmail.com>
|
||||
Date: Sat, 16 May 2020 20:01:33 +0200
|
||||
Subject: [PATCH] Always use system onig
|
||||
|
||||
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
build.rs | 6 ++----
|
||||
src/lib.rs | 12 ------------
|
||||
2 files changed, 2 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/build.rs b/build.rs
|
||||
index c7cb1fa..2155fe2 100644
|
||||
--- a/build.rs
|
||||
+++ b/build.rs
|
||||
@@ -1,4 +1,3 @@
|
||||
-#[cfg(feature = "generate")]
|
||||
extern crate bindgen;
|
||||
extern crate cc;
|
||||
extern crate pkg_config;
|
||||
@@ -187,7 +186,6 @@ fn compile() {
|
||||
}
|
||||
|
||||
fn bindgen_headers(_path: &str) {
|
||||
- #[cfg(feature = "generate")]
|
||||
{
|
||||
let bindings = bindgen::Builder::default()
|
||||
.header(_path)
|
||||
@@ -205,13 +203,13 @@ fn bindgen_headers(_path: &str) {
|
||||
|
||||
pub fn main() {
|
||||
let link_type = link_type_override();
|
||||
- let require_pkg_config = env_var_bool("RUSTONIG_SYSTEM_LIBONIG").unwrap_or(false);
|
||||
+ let require_pkg_config = true;
|
||||
|
||||
if require_pkg_config || link_type == Some(LinkType::Dynamic) {
|
||||
let mut conf = Config::new();
|
||||
// dynamically-generated headers can work with an older version
|
||||
// pre-generated headers are for the latest
|
||||
- conf.atleast_version(if cfg!(feature = "generate") {"6.8.0"} else {"6.9.3"});
|
||||
+ conf.atleast_version("6.8.0");
|
||||
if link_type == Some(LinkType::Static) {
|
||||
conf.statik(true);
|
||||
}
|
||||
diff --git a/src/lib.rs b/src/lib.rs
|
||||
index 4d855ad..c9b6d20 100644
|
||||
--- a/src/lib.rs
|
||||
+++ b/src/lib.rs
|
||||
@@ -1,19 +1,7 @@
|
||||
-#[cfg(feature = "generate")]
|
||||
mod bindgened;
|
||||
|
||||
-#[cfg(feature = "generate")]
|
||||
pub use bindgened::*;
|
||||
|
||||
-#[cfg(not(feature = "generate"))]
|
||||
-#[allow(non_upper_case_globals)]
|
||||
-#[allow(non_camel_case_types)]
|
||||
-#[allow(non_snake_case)]
|
||||
-#[allow(clippy::all)]
|
||||
-mod ffi;
|
||||
-
|
||||
-#[cfg(not(feature = "generate"))]
|
||||
-pub use self::ffi::*;
|
||||
-
|
||||
// backfill types from the old hand-written bindings:
|
||||
|
||||
pub type OnigSyntaxBehavior = ::std::os::raw::c_uint;
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- onig_sys-69.2.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ onig_sys-69.2.0/Cargo.toml 2020-02-27T23:05:59.827511+00:00
|
||||
@@ -23,7 +23,7 @@
|
||||
license = "MIT"
|
||||
repository = "http://github.com/iwillspeak/rust-onig"
|
||||
[build-dependencies.bindgen]
|
||||
-version = "0.50"
|
||||
+version = "0.53"
|
||||
|
||||
[build-dependencies.cc]
|
||||
version = "1.0"
|
@ -1,12 +0,0 @@
|
||||
diff -uNr onig_sys-68.2.0.orig/build.rs onig_sys-68.2.0/build.rs
|
||||
--- onig_sys-68.2.0.orig/build.rs 2018-07-29 18:29:19.000000000 +0200
|
||||
+++ onig_sys-68.2.0/build.rs 2018-09-03 08:36:08.969948474 +0200
|
||||
@@ -139,7 +139,7 @@
|
||||
|
||||
pub fn main() {
|
||||
let link_type = link_type_override();
|
||||
- let require_pkg_config = env_var_bool("RUSTONIG_SYSTEM_LIBONIG").unwrap_or(false);
|
||||
+ let require_pkg_config = env_var_bool("RUSTONIG_SYSTEM_LIBONIG").unwrap_or(true);
|
||||
|
||||
if require_pkg_config || link_type == Some(LinkType::Dynamic) {
|
||||
let mut conf = Config::new();
|
@ -1 +1 @@
|
||||
SHA512 (onig_sys-69.2.0.crate) = 279d08cbb6169f34f836812b44179a2efe12b7676ae424c27fee624d2b8d609c8015608c09e2d4adeaffe66308822263d9d0399ab2169dfa749ec73233eafdbc
|
||||
SHA512 (onig_sys-69.5.0.crate) = 644019ca67a89790bab5cb173f5499bf3b0af5a4c39e027e79a63e5752f471c6bff86f679e1c86502b6c3cf795c23cd461a87c36b2eb687dfe21e9d232bcb7ac
|
||||
|
Loading…
Reference in new issue