Update to 69.7.1 Close: rhbz#1970059

epel9
Robert-André Mauchin 3 years ago
parent 32046f864f
commit 301e2a6148

1
.gitignore vendored

@ -6,3 +6,4 @@
/onig_sys-69.5.0.crate
/onig_sys-69.5.1.crate
/onig_sys-69.6.0.crate
/onig_sys-69.7.1.crate

@ -18,7 +18,7 @@ index cf1b6f3..d704fce 100644
extern crate bindgen;
extern crate cc;
extern crate pkg_config;
@@ -196,10 +195,6 @@ fn compile() {
@@ -198,10 +197,6 @@ fn compile() {
cc.compile("onig");
}
@ -29,7 +29,7 @@ index cf1b6f3..d704fce 100644
fn bindgen_headers(path: &str) {
let arch = env::var("CARGO_CFG_TARGET_ARCH");
let mut bindgen = bindgen::Builder::default()
@@ -219,17 +214,13 @@ fn bindgen_headers(path: &str) {
@@ -221,17 +216,13 @@ fn bindgen_headers(path: &str) {
pub fn main() {
let link_type = link_type_override();

@ -1,13 +1,13 @@
--- onig_sys-69.6.0/Cargo.toml 2020-11-22T10:29:19+00:00
+++ onig_sys-69.6.0/Cargo.toml 2021-03-31T18:46:59.514001+00:00
--- onig_sys-69.7.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ onig_sys-69.7.1/Cargo.toml 2021-11-13T17:55:04.245041+00:00
@@ -23,9 +23,7 @@
license = "MIT"
repository = "http://github.com/iwillspeak/rust-onig"
[build-dependencies.bindgen]
-version = "0.55"
-version = "0.56"
-features = ["runtime"]
-optional = true
+version = "0.57"
+version = "0.59"
[build-dependencies.cc]
version = "1.0"

@ -1,20 +1,20 @@
# Generated by rust2rpm 17
# Generated by rust2rpm 18
%bcond_without check
%global debug_package %{nil}
%global crate onig_sys
Name: rust-%{crate}
Version: 69.6.0
Version: 69.7.1
Release: %autorelease
Summary: Raw rust bindings to the oniguruma library
Summary: `onig_sys` crate contains raw rust bindings to the oniguruma library
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/onig_sys
Source: %{crates_source}
# Initial patched metadata
# * Bump bindgen to 0.57: https://github.com/rust-onig/rust-onig/pull/157
# * Bump bindgen to 0.59
# * Mark bindgen as non-optional dep (for next patch)
Patch0: onig_sys-fix-metadata.diff
# Always use system onig

@ -1 +1 @@
SHA512 (onig_sys-69.6.0.crate) = 79903461da8cdacf3f50c7f4d7a1babb200a883a3fa6515119a6d2a82c15eb64b7f758932a2a8c46f89acd052d8f2ab84cf87bf16a3ec9c570667232f54418f5
SHA512 (onig_sys-69.7.1.crate) = 5be8c31049ad741fa06247bd22813374f71397481cea22be3d83bed720b512b9cb10d6028072fd92cc09ac0e9ca8fb977ca49fb59d934dd61f84c4634d28ffb3

Loading…
Cancel
Save