Update parking_lot to 0.8

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 27484e84d9
commit d3672b03ea
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,5 +1,5 @@
--- once_cell-0.1.8/Cargo.toml 1970-01-01T01:00:00+01:00 --- once_cell-0.1.8/Cargo.toml 1970-01-01T00:00:00+00:00
+++ once_cell-0.1.8/Cargo.toml 2019-02-12T08:54:21.124719+01:00 +++ once_cell-0.1.8/Cargo.toml 2019-05-07T05:37:53.908717+00:00
@@ -14,7 +14,7 @@ @@ -14,7 +14,7 @@
name = "once_cell" name = "once_cell"
version = "0.1.8" version = "0.1.8"
@ -9,3 +9,12 @@
description = "Single assignment cells and lazy static values without macros." description = "Single assignment cells and lazy static values without macros."
documentation = "https://docs.rs/once_cell" documentation = "https://docs.rs/once_cell"
readme = "README.md" readme = "README.md"
@@ -23,7 +23,7 @@
license = "MIT OR Apache-2.0"
repository = "https://github.com/matklad/once_cell"
[dependencies.parking_lot]
-version = "0.7.1"
+version = "0.8"
optional = true
default_features = false
[dev-dependencies.crossbeam-utils]

@ -1,5 +1,4 @@
# Generated by rust2rpm # Generated by rust2rpm-9-1.fc31
# * Tests are run in infrastructure
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
@ -7,7 +6,7 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.1.8 Version: 0.1.8
Release: 2%{?dist} Release: 3%{?dist}
Summary: Single assignment cells and lazy static values without macros Summary: Single assignment cells and lazy static values without macros
# Upstream license specification: MIT OR Apache-2.0 # Upstream license specification: MIT OR Apache-2.0
@ -15,13 +14,14 @@ License: MIT or ASL 2.0
URL: https://crates.io/crates/once_cell URL: https://crates.io/crates/once_cell
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * Exclude unnecessary files # * Exclude unnecessary files, https://github.com/matklad/once_cell/pull/12
# * Update parking_lot to 0.8, https://github.com/matklad/once_cell/pull/11
Patch0: once_cell-fix-metadata.diff Patch0: once_cell-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(parking_lot) >= 0.7.1 with crate(parking_lot) < 0.8.0) BuildRequires: (crate(parking_lot) >= 0.8.0 with crate(parking_lot) < 0.9.0)
%if %{with check} %if %{with check}
BuildRequires: (crate(crossbeam-utils/default) >= 0.6.0 with crate(crossbeam-utils/default) < 0.7.0) BuildRequires: (crate(crossbeam-utils/default) >= 0.6.0 with crate(crossbeam-utils/default) < 0.7.0)
%endif %endif
@ -85,6 +85,9 @@ which use "parking_lot" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Tue May 07 07:37:55 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.8-1
- Update parking_lot to 0.8
* Tue Feb 12 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.8-2 * Tue Feb 12 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.8-2
- Adapt to new packaging - Adapt to new packaging

Loading…
Cancel
Save