|
|
|
@ -1,6 +1,6 @@
|
|
|
|
|
--- object-0.24.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
|
|
|
|
+++ object-0.24.0/Cargo.toml 2021-05-08T18:20:50.956784+00:00
|
|
|
|
|
@@ -46,19 +46,6 @@
|
|
|
|
|
--- object-0.26.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
|
|
|
|
+++ object-0.26.2/Cargo.toml 2021-09-21T21:07:44.960855+00:00
|
|
|
|
|
@@ -45,19 +45,6 @@
|
|
|
|
|
[[example]]
|
|
|
|
|
name = "readobj"
|
|
|
|
|
required-features = ["read"]
|
|
|
|
@ -20,22 +20,28 @@
|
|
|
|
|
|
|
|
|
|
[dependencies.crc32fast]
|
|
|
|
|
version = "1.2"
|
|
|
|
|
@@ -72,9 +59,6 @@
|
|
|
|
|
version = "1.1"
|
|
|
|
|
optional = true
|
|
|
|
|
@@ -75,14 +62,11 @@
|
|
|
|
|
version = "2.4.1"
|
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
-[dependencies.wasmparser]
|
|
|
|
|
-version = "0.57"
|
|
|
|
|
-optional = true
|
|
|
|
|
[dev-dependencies.memmap]
|
|
|
|
|
version = "0.7"
|
|
|
|
|
[dev-dependencies.memmap2]
|
|
|
|
|
version = "0.3"
|
|
|
|
|
|
|
|
|
|
@@ -90,9 +74,7 @@
|
|
|
|
|
[features]
|
|
|
|
|
-all = ["read", "write", "std", "compression", "wasm"]
|
|
|
|
|
+all = ["read", "write", "std", "compression"]
|
|
|
|
|
archive = []
|
|
|
|
|
cargo-all = []
|
|
|
|
|
coff = []
|
|
|
|
|
@@ -93,9 +77,7 @@
|
|
|
|
|
pe = ["coff"]
|
|
|
|
|
read = ["read_core", "archive", "coff", "elf", "macho", "pe", "unaligned"]
|
|
|
|
|
read_core = []
|
|
|
|
|
-rustc-dep-of-std = ["core", "compiler_builtins", "alloc"]
|
|
|
|
|
std = []
|
|
|
|
|
-rustc-dep-of-std = ["core", "compiler_builtins", "alloc", "memchr/rustc-dep-of-std"]
|
|
|
|
|
std = ["memchr/std"]
|
|
|
|
|
unaligned = []
|
|
|
|
|
-wasm = ["wasmparser"]
|
|
|
|
|
write = ["write_core", "coff", "elf", "macho"]
|
|
|
|
|