Update to version 0.36.2; Fixes RHBZ#2267848

Signed-off-by: Michel Lind <salimma@fedoraproject.org>
epel10
Michel Lind 7 months ago committed by Fabio Valentini
parent 7d0b2fc491
commit a48fbb92c1
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

2
.gitignore vendored

@ -16,3 +16,5 @@
/object-0.30.3.crate
/object-0.32.1.crate
/object-0.32.2.crate
/object-0.36.1.crate
/object-0.36.2.crate

@ -1,24 +1,26 @@
--- object-0.32.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ object-0.32.2/Cargo.toml 2023-12-27T19:50:43.679682+00:00
@@ -76,17 +76,12 @@
version = "0.5.0"
--- object-0.36.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ object-0.36.2/Cargo.toml 2024-07-24T21:05:06.120075+00:00
@@ -81,11 +81,6 @@
version = "0.7.0"
optional = true
-[dependencies.wasmparser]
-version = "0.118.0"
-version = "0.214.0"
-optional = true
-default-features = false
-
[features]
all = [
"read",
"write",
@@ -93,7 +88,6 @@
"build",
"std",
"compression",
- "wasm",
]
archive = []
cargo-all = []
@@ -110,7 +105,6 @@
build = [
@@ -127,7 +121,6 @@
"elf",
"macho",
"pe",
@ -26,7 +28,7 @@
"xcoff",
]
elf = []
@@ -140,7 +134,6 @@
@@ -157,7 +150,6 @@
"all",
"unstable",
]

@ -1,11 +1,11 @@
# Generated by rust2rpm 25
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate object
Name: rust-object
Version: 0.32.2
Version: 0.36.2
Release: %autorelease
Summary: Unified interface for reading and writing object file formats
@ -13,7 +13,6 @@ License: Apache-2.0 OR MIT
URL: https://crates.io/crates/object
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * bump ruzstd dependency from 0.4 to 0.5
# * disable unused WASM support
Patch: object-fix-metadata.diff
@ -76,6 +75,30 @@ use the "archive" feature of the "%{crate}" crate.
%files -n %{name}+archive-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+build-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+build-devel %{_description}
This package contains library source intended for building other packages which
use the "build" feature of the "%{crate}" crate.
%files -n %{name}+build-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+build_core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+build_core-devel %{_description}
This package contains library source intended for building other packages which
use the "build_core" feature of the "%{crate}" crate.
%files -n %{name}+build_core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cargo-all-devel
Summary: %{summary}
BuildArch: noarch
@ -296,7 +319,7 @@ use the "xcoff" feature of the "%{crate}" crate.
%if %{with check}
%check
# * skip tests that require files which are not included in published crates
%cargo_test -- -- --exact --skip read::coff::coff_extended_relocations
%cargo_test -- -- --exact --skip read::coff::coff_extended_relocations --skip read::elf::get_buildid_bad_elf --skip read::elf::get_buildid_less_bad_elf --skip read::macho::test_go_macho
%endif
%changelog

@ -7,7 +7,12 @@ hide = [
]
[tests]
skip = ["read::coff::coff_extended_relocations"]
skip = [
"read::coff::coff_extended_relocations",
"read::elf::get_buildid_bad_elf",
"read::elf::get_buildid_less_bad_elf",
"read::macho::test_go_macho",
]
skip-exact = true
comments = ["skip tests that require files which are not included in published crates"]

@ -1 +1 @@
SHA512 (object-0.32.2.crate) = 5d03d998f06dc592c3be141f7163bd72a0e73396f95d22ef1e0ffbfc66489bf727a6f6fb813a32739609b619b8e34a471974b2231dcfa23df8bff52007c25a96
SHA512 (object-0.36.2.crate) = f5adb662c0e6e184a75c14181d70f3c9d8d6f4002fcb9082863c9c7a28f36d35464168c7447e63316c0227d38d92eec73240665afdecfa574eb625b040854ef9

Loading…
Cancel
Save